Installation fail on Fedora 32 - Compiler version mismatch

Hi
I purchased the RXT2070 yesterday and installed it. Works fine on Windows but on the dual boot Fedora32 I have a failed install using either of ‘dnf install akmod-nvidia’ or by running the Nvidia*.run file downloaded from website. It fails on the DKMS part …
Error message is

DKMS make.log for nvidia-440.59 for kernel 5.7.11-200.fc32.x86_64 (x86_64)
Thursday 06 August 2020 12:34:06 PM IST
make[1]: Entering directory ‘/usr/src/kernels/5.7.11-200.fc32.x86_64’
SYMLINK /var/lib/dkms/nvidia/440.59/build/nvidia/nv-kernel.o
SYMLINK /var/lib/dkms/nvidia/440.59/build/nvidia-modeset/nv-modeset-kernel.o

Compiler version check failed:

The major and minor number of the compiler used to
compile the kernel:

gcc version 10.1.1 20200507 (Red Hat 10.1.1-1) (GCC), GNU ld version 2.34-4.fc32 does not match the compiler used here: cc (GCC) 10.2.1 20200723 (Red Hat 10.2.1-1)

I tried setting the IGNORE_CC_MISMATCH=1 with no luck.

How to fix this?

For the .run installer, the --no-cc-version-check parameter should bypass the check.

Thanks for the reply. Yes I did try that it did not work for the 440.59. Then I discovered there was a newer 450.57 version which installed correctly. However all is not well - the screen is low resolution 1024x768 and the boot message fonts are fat and blurry and completely unreadable. Switching to CTRL+F2 terminal shows readable fonts still in 1024x768. Attaching the boot logs in case anyone can help me figure what went wrong. XWayland does not start.

EDIT: – Deleted uploaded logs –

Adding the install log as well:
An interesting event was that for all the failed installs the kernel boot commandline was correctly updated. For the succesfull install it was not and I added this manually - ‘rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1

Bwaah! There was a leftover amdgpu config in /etc/X11/xorg.conf.d/xorg.conf I thought I had cleaned out. I must have missed it in the lowres mode and confusion about whats happening.

I reviewed the boot messages once again and sure enought the amdgpu load lines were logged - this was preventing the Nvidia driver from loading.

Deleted the xorg.conf and rebooted. Problem Solved!

dmesg | grep -iE “VGA|nvidia”
[ 0.000000] Command line: BOOT_IMAGE=(hd0,gpt7)/vmlinuz-5.7.11-200.fc32.x86_64 root=UUID=98b6726d-7dd6-4b40-a854-0ee7908b4aa3 ro resume=UUID=c99e4dbe-a9bd-4a73-b035-858c38e2a273 iommu=pt amd_iommu_intr=vapic rhgb nodmraid rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1
[ 0.000000] Kernel command line: BOOT_IMAGE=(hd0,gpt7)/vmlinuz-5.7.11-200.fc32.x86_64 root=UUID=98b6726d-7dd6-4b40-a854-0ee7908b4aa3 ro resume=UUID=c99e4dbe-a9bd-4a73-b035-858c38e2a273 iommu=pt amd_iommu_intr=vapic rhgb nodmraid rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1
[ 0.241019] pci 0000:26:00.0: vgaarb: VGA device added: decodes=io+mem,owns=none,locks=none
[ 0.241019] pci 0000:26:00.0: vgaarb: bridge control possible
[ 0.241019] pci 0000:26:00.0: vgaarb: setting as boot device
[ 0.241019] vgaarb: loaded
[ 0.541086] fb0: EFI VGA frame buffer device
[ 4.362400] nvidia-gpu 0000:26:00.3: enabling device (0000 -> 0002)
[ 4.537204] snd_hda_intel 0000:26:00.1: Handle vga_switcheroo audio client
[ 4.590991] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:03.1/0000:26:00.1/sound/card0/input20
[ 4.592168] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:03.1/0000:26:00.1/sound/card0/input21
[ 4.593163] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:03.1/0000:26:00.1/sound/card0/input22
[ 4.594139] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:03.1/0000:26:00.1/sound/card0/input23
[ 4.595098] input: HDA NVidia HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:03.1/0000:26:00.1/sound/card0/input24
[ 4.595733] input: HDA NVidia HDMI/DP,pcm=11 as /devices/pci0000:00/0000:00:03.1/0000:26:00.1/sound/card0/input25
[ 4.596237] input: HDA NVidia HDMI/DP,pcm=12 as /devices/pci0000:00/0000:00:03.1/0000:26:00.1/sound/card0/input26
[ 4.907251] nvidia: loading out-of-tree module taints kernel.
[ 4.908180] nvidia: module license ‘NVIDIA’ taints kernel.
[ 4.913347] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[ 4.933702] nvidia-nvlink: Nvlink Core is being initialized, major device number 239
[ 4.934900] nvidia 0000:26:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=io+mem
[ 4.979076] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 450.57 Sun Jul 5 14:42:25 UTC 2020
[ 5.020841] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms 450.57 Sun Jul 5 14:52:29 UTC 2020
[ 5.026488] [drm] [nvidia-drm] [GPU ID 0x00002600] Loading driver
[ 5.538012] nvidia-gpu 0000:26:00.3: i2c timeout error e0000000
[ 6.249369] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:26:00.0 on minor 0

Posted this from Fedora now!