Installation of tensorflow failed

Jetpack : 4.6.4
I can’t install h5py of version 3.1.0 for tesorflow.


The directive I use is: sudo env H5PY_SETUP_REQUIRES=0 pip3 install -U h5py==3.1.0

The relevant posts on the forum have been tried, but nothing works

Hi,

Based on the error message, could you run the below command and try it again?

$ sudo pip3 install -U cython 

Thanks.

Hi,
Thank you very much for your reply, but it still shows the same error.


I’ve tried to install it many times, and it’s all from here that I get an error.
Thanks.

Hi,
I also tried jetpack 4.6.1 .It shows the same error. It is not yet possible to download CUDA with instructions.Does anyone have a solution, thank you very much.

Hi,

Could you check the command shared in the below link?

If the error still exists, could you share the complete output log so we can check which library or tool is missing in your environment?
Thanks.

Hi,
I’ve tried and it’s still the same error.
New Text Document (5).txt (44.8 KB)
Thanks.

Hi,
Sorry to bother you again. Do you have any clues over there. I’ve been stuck here for a long time. Also tried many methods. But nothing came of it.
Thanks.

Hi,

Could you try if the below commands work for you?

$ sudo apt-get update
$ sudo apt-get install libhdf5-serial-dev hdf5-tools libhdf5-dev zlib1g-dev zip libjpeg8-dev liblapack-dev libblas-dev gfortran
$ sudo apt-get install python3-pip
$ sudo python3 -m pip install --upgrade pip
$ sudo pip3 install -U testresources setuptools==65.5.0
$ sudo pip3 install -U numpy future==0.18.2 mock==3.0.5 keras_preprocessing==1.1.2 keras_applications==1.0.8 gast==0.4.0 protobuf pybind11 cython pkgconfig packaging h5py==3.6.0

Thanks

Hi,
Thank you very much for your help. I’ve tried it before. However, the error is as follows:

I really can’t find any good way to solve it. Can I trouble you to help me take a look again.
Thanks

Hi,

Could you share the JetPack version with us?

$ cat /etc/nv_tegra_release

Thanks.

Hi,
Thanks for your reply.

Thanks

Hi,
Excuse me, is there any method that can be used to refer to it.
Thanks

Hi,

This issue is caused by the recent update in h5py.
We are working on solving the compatibility issue.

Hope to update more info with you soon.

Thanks.

Hi,
Thank you so much. Looking forward to your good news.
Thanks

Hi,

Please check below topic for the details:

Thanks.

Hi,
Could you please provide the image of tensorflow installed.My installation is still the same error.
Thanks

Hi,

Please check the link above.
There are some dependencies so you will need to install a certain version library to ensure compatibility.

Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.