Installing cuda 10 in ubuntu 18.04 arm64 based docker running on AGX

Hello,

I’m trying to install cuda 10 in a docker containing ubuntu 18.04 that run on AGX.

I successfully created the docker containing ubuntu18.04 and launched the container on the AGX but I’m stuck by the installation of cuda 10. I’m following this doc https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html but I’m unable to get the linux headers at point 2.4 of the doc.

I made some research about installing cuda on a arm64 but found nothing that helped me.

Have someone any idea how to achieve this or can point me to a dockerfile that already does it.

Thanks in advance for your responses

Cortexia

Hi,

We don’t support x86-based CUDA toolkit within docker on the Jetson yet.
But you can install an aarch64-based package based on the similar instructions shared here:
https://github.com/Technica-Corporation/Tegra-Docker

Thanks.

Thanks for the answer and the link !

We had seen this repo, and unsuccessfully tried it (probably because we are using the Xavier)

We also have tried to build an image from scratch (https://hub.docker.com/_/ubuntu) but we hit the wall when trying to install CUDA (no apt packages for arm64)

Any advices ?

Hi,

May I know the error when you testing the GitHub.
The sample should work well on all Jetson platform.

Since nvidia-docker doesn’t support x86-based container on Jetson, the way to use Tegra GPU is directly mounting the hardware node.
This is the Tegra-Docker repository applied.

It’s recommended to follow the instructions shared in the GitHub:
You can start with this script first: https://github.com/Technica-Corporation/Tegra-Docker/blob/master/bin/tx2-docker

Thanks.

I need to reproduce, and go through the steps once again. I will try to do it next week