Installing CUDA on Ubuntu 8.04 Help needed in installation

Hello everyone,

Maybe I’m doing something terribly wrong, but CUDA refuses to run install on an Ubuntu 8.04 machine. It keeps saying

/usr/bin/ld: cannot find -lcuda

collect2: ld returned 1 exit status

Could this be because I’m trying to install CUDA 2.0 on the 169 version of the NVIDIA driver?

I tried searching for libcuda.so, but couldn’t find it anywhere.

Could someone please tell me what I’m doing wrong?

Thanks in advance.

You need to use 177.13 if you’re using CUDA 2.0b2. The CUDA capabilities are driver dependent, so 169.02 will not work.

If you installed the official NVIDIA driver package, then libcuda.so gets installed in /usr/lib .

If you’re using an Ubuntu provided driver package, then you should contact the package maintainer for assistance.

I have now switched to driver 177.13, and the problem has shifted to finding -lcudart.so

ld keeps saying that it skipping an incompatible libcudart.so

Any help?

:oops: just made a fool of myself…

anyways, my story of installing cuda on ubuntu:
1- Remove all nvidia drivers!
2- clean the system of anything nvidia
3- in safe mode do fixing of broken drivers
4- run this
sudo aptitude install build-essential libncurses-dev gettext
linux-headers-uname -r
5. get the correct version of cuda toolkit and sdk to install on your system
6. install them

thanks everyone… i wonder why doing this took so long?

Here is a guide for setting up CUDA in Ubuntu 8.04. It’s kind of a hack - it doesn’t use the NVidia driver installers like you managed to, but it worked for me.

Thanks Curran.Your blog was extremely helpful in getting CUDA to run in Linux on my Macbook Pro.

hi…

while doing make i get this error:

mascarpone@mascarpone-desktop:~/NVIDIA_CUDA_SDK$ make

make[1]: Entering directory `/home/mascarpone/NVIDIA_CUDA_SDK/common'

a - obj/release/bank_checker.cpp_o

a - obj/release/cmd_arg_reader.cpp_o

a - obj/release/cutil.cpp_o

a - obj/release/stopwatch.cpp_o

a - obj/release/stopwatch_linux.cpp_o

a - obj/release/multithreading.cpp_o

ar: could not create temporary file whilst writing archive: No more archived files

make[1]: *** [../lib/libcutil.a] Error 1

make[1]: Leaving directory `/home/mascarpone/NVIDIA_CUDA_SDK/common'

make: *** [lib/libcutil.so] Error 2

why???

Solved= you just have to set permissions…

$ sudo chmod -R 777 /NVIDIA_CUDA_SDK