Installing Flash Tegra A 5.0.5.0 failed.

Hello,

when i was trying to install Driveworks 5.0.5.0, i met an error. Here is the error report,
please support to fix it. Thanks.


Aurix port /dev/ttyUSB1 does not exist

Bootburn operation unsuccessful

The following tips can help troubleshoot bootburn failures. These are based on
known issues related to setup or missing configuration. If it doesn’t help
resolve the issue, contact module owners with a copy of the full log.

error= error-aurix-port

  • No tips currently available for this failure

Dear BjoernFathIPG,
Please find latest Drive release at https://developer.nvidia.com/nvidia-drive-downloads.
Could you please check below “Download and Install DriveInstall 5.0.5.0b Linux” guidance for your topic? Thanks.
https://docs.nvidia.com/drive/driveinstall_docs/#developertools/mobile/driveinstall/linux/5.0.5.0b/sdk/install.htm%3FTocPath%3D_____3

Hello,

yes, i installed Driveworks as the manual, but there is one tip i am not very sure what it mean.

  • Make sure to EXIT ALL minicom terminal windows connected to the DRIVE PX 2 device.

i didn’t open any minicom terminal windows, is that correct?

another, why it logs /dev/ttyUSB1 is not found? need to change the minicom default setting?

thanks.

Dear BjoernFathIPG,
Please double check if you have connected Host PC USB port with Drive PX2 USB 2.0 Debug port(Not Drive Px2 USB 3.0 port) before flashing. After connecting, ls /dev/ttyUSB* should list 8 devices.

hello,

yes, i checked there are 8 devices ttyUSB 0-7 have been found. but during flashing, these 8 ports will disappear from the list. i am assuming maybe it is the cable issue. have you met this cable issue before?

thanks

HI,

Has this been resolved?

I am having difficulties with the flashing of DRIVE 5.0.10.3 SDK WITH DRIVEWORKS LINUX FOR DRIVE PX 2 AUTOCHAUFFEUR.

Unsuccessful in flashing Tegra A or Tegra B or together.

From error report,


Target will be flashed with rootfs in eMMC
Aurix Port = /dev/ttyUSB1
Successfully acquired lock over /var/lock/LCK…bootburn_seq
Successfully acquired lock over /var/lock/LCK…ttyUSB1
Disabling SIGINT <Ctrl+C> temporarily
Setting Tegra-A on hold…cat: /dev/ttyUSB1: Resource temporarily unavailable
Could not execute command “tegrareset a h” on aurix. Log follows,

------------ Stack Trace ------------
stack frame 0 - 384 AbnormalTermination /home/cetranpx2/nvidia/nvidia_sdk/DRIVE/Linux/5.0.10.3/OS/DriveSDK/drive-t186ref-foundation/tools/host/flashtools/bootburn/bootburn_lib.sh
stack frame 1 - 284 ExecuteAurixCommand /home/cetranpx2/nvidia/nvidia_sdk/DRIVE/Linux/5.0.10.3/OS/DriveSDK/drive-t186ref-foundation/tools/host/flashtools/bootburn/bootburn_target.sh
stack frame 2 - 134 GetTegrasAssocWithAurix /home/cetranpx2/nvidia/nvidia_sdk/DRIVE/Linux/5.0.10.3/OS/DriveSDK/drive-t186ref-foundation/tools/host/flashtools/bootburn/bootburn_target.sh
stack frame 3 - 360 CheckRecoveryTargets /home/cetranpx2/nvidia/nvidia_sdk/DRIVE/Linux/5.0.10.3/OS/DriveSDK/drive-t186ref-foundation/tools/host/flashtools/bootburn/bootburn_target.sh
stack frame 4 - 457 SequencerSetupTarget /home/cetranpx2/nvidia/nvidia_sdk/DRIVE/Linux/5.0.10.3/OS/DriveSDK/drive-t186ref-foundation/tools/host/flashtools/bootburn/bootburn_sequencer.sh
stack frame 5 - 475 SeqFlashTarget /home/cetranpx2/nvidia/nvidia_sdk/DRIVE/Linux/5.0.10.3/OS/DriveSDK/drive-t186ref-foundation/tools/host/flashtools/bootburn/bootburn_sequencer.sh
stack frame 6 - 518 source /home/cetranpx2/nvidia/nvidia_sdk/DRIVE/Linux/5.0.10.3/OS/DriveSDK/drive-t186ref-foundation/tools/host/flashtools/bootburn/bootburn_sequencer.sh
stack frame 7 - 318 source /home/cetranpx2/nvidia/nvidia_sdk/DRIVE/Linux/5.0.10.3/OS/DriveSDK/drive-t186ref-foundation/tools/host/flashtools/bootburn/bootburn_core.sh
stack frame 8 - 44 main tools/host/flashtools/bootburn/bootburn.sh

error-aurix-command
Unable to restore Aurix Console Params

Bootburn operation unsuccessful

The following tips can help troubleshoot bootburn failures. These are based on
known issues related to setup or missing configuration. If it doesn’t help
resolve the issue, contact module owners with a copy of the full log.

error= error-aurix-command

  • The Aurix console did not regognize the command given to it. Please review
    the logs and make sure that the command that you are sending is valid

bootburn flashing failed! error code = 37


“ls /dev/ttyUSB*” gives me 8 devices

For your assistance please.

further details:

Host information:

OS : ubuntu 16.04 LTS 64-bit

uname -a -> [ Linux cetranpx2-OptiPlex-7040 4.15.0-45-generic #48~16.04.1-Ubuntu SMP Tue Jan 29 18:03:48 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux ]

hostname -I -> [ 172.21.76.1 ]

Target information:

Tegra B

OS : ubuntu 16.04 LTS 64-bit

uname -a -> Linux nvidia 4.4.38-rt49-tegra #1 SMP PREEMPT RT Tue Jul 25 09:26:02 PDT 2017 aarch64 aarch64 aarch64 GNU/Linux

hostname -I -> [ 172.21.76.218 ]

Dear Mohd.azhar,
notice issues with ubuntu 16.04 with latest kernels. We are working to fix this issue. Could you please check with ubuntu 14.04 host or with downgrade your linux kernel version( ex. 4.15.0-32) and check installing?

I have initially installed Ubuntu 18.04 and later downgraded to 16.04 after seeing the documentation that DPX2 can only be flashed with 14.04 or 16.04. Now, I have to again downgrade to install DPX2. Is there any other fix than this?.

Dear ram469,
The issue is because of Kernel version. Please check https://devtalk.nvidia.com/default/topic/1047490/faq/flashing-issues-on-drive-px2-amp-drive-agx-xavier/ for more details.