Installing Mediapipe on Jetson Nano(4gb)

Hi, I’m trying to download Mediapipe on Jetson Nano 4gb kit. I have a 32gb micro SD card in it with JetPack 4.6 installed. I followed the GitHub tutorial I used to try to install mediapipe but I get errors related to “fatal error: certificate verification failed, Handshake failed” when I try to run commands like
“sudo apt update” and “sudo apt-get update”. I’m very new user of Jetson Nano. Please help me out! All help is appreciated!

I also found a website explaining step by step how to resolve my issue but that didn’t work either. Like in down below:

How to Solve Certificate Verification Error During APT Update on Jetso

I only tried method 1 and 2 from this website as the third one has removal of certificate verification security.

Please help me if you’ve resolved the issue. (I’m a newbie). Thanks in advance!

Hi dhairyasachdeva11,

Which “GitHub tutorial” you followed?

“sudo apt update” is just used for updating your repository.
Please make sure that your board could access network normally first.

Yes I wasn’t able to post 2 links in one post being a new member.
The GitHub tutorial I followed:

The error statement I was getting when I ran the command
Sudo apt update
Error: Certificate verification failed: The certificate is NOT trusted. The certificate chain uses not yet valid certificate. Could not handshake: Error in the certificate verification.

Where do you execute “sudo apt update”? (host machine or target jetson Nano board)
If you execute this on Jetson Nano, do you check your network connection before?

I am facing the same error.
When i run the command ‘sudo apt update’ on my jetson nano, i am getting this error :

I’m writing this command on the terminal on the jetson board itself. And yes I’m using a private Ethernet enabled internet connection which is working (chromium works on it just fine).
The error reads:
N: Ignoring file ‘Nvidia-l4t-apt-source.listt’ in directory ‘/etc/apt/sources.list.d/‘ as it has an invalid filename extension”

Could you provide /etc/apt/sources.list.d/nvidia-l4t-apt-source.list from your board for further check?

I’ve check inside the directory “/etc/apt/sources.list.d” has 2 files and I’m not sure if this should be the case one has extension “.list” and the other has “.listt” as in the picture shown.
Do I need to delete the “.listt” file?

Could you check the content between these two files?
Check if there’s any difference.
If there are similar, you could try to remove the file with extension “.listt” and update repository again.

The file with “.listt” is empty (read only file) and “.list” has 2 statements :

You could try to remove “nvidia-l4t-apt-source.listt” and run “sudo apt update”

Yes that works thanks a lot for the help! Can I also ask if you know how to install Python packages like CVzone from GitHub as well into the Jetson nano and use it in a .py file?

The Linux based OS (Ubuntu) is operated in Jetson Nano.
Therefore, most of the Linux commands are available for use.

You can follow the instruction from GitHub project
Or just refer to the python official tutorial:
Installing Packages — Python Packaging User Guide

Thanks for the reply! I’ve installed it already