Installing Mini-PCIe Board on TX2 Devboard

Hi all,

we’re trying to install the Sensoray 1012 on the Jetson TX2 devboard, which is a mini PCIe card. Thus we have an adapter for the M.2 slot to mini PCIe where the Sensoray 1012 is connected to. However, lspci shows an empty list.

I already found https://devtalk.nvidia.com/default/topic/1027594/using-the-development-kit-m-2-e-key-slot-for-an-fpga/ stating that we first have to activate the PCIe lanes on that M.2 connector. Unfortunately, I cannot find the pdf mentioned there to get help. Also I cannot find the P2771-0000.common.conf which has be changed (?) on the Jetson TX2. I also installed the JetPack on my Ubuntu system but there is also no P2771-0000.common.conf and no documentation that could help.

Thx for the help in advance!

werbenirvana,

Please take a look at this page and TX2 adaptation guide to enable M.2 pcie.

https://elinux.org/Jetson/TX2_USB#USB-Lane_Mapping (Please note that the example is config #3, not suitable for carrier board with 0~1 usb ports)

It requires to modify the device tree. For your case, because you don’t need more usb ports, configuration #1 is what you need.

If you have any problem, please let me know.

Thx a lot, it seems I successfully flashed it as the USB ports seem to be offline. I thought they only will have less lanes, so USB 2 speed but this seems to be wrong.

Should config 5 or 6 also work (with less speed) but then with USB? If yes, it’s not clear to me how to calculate the ODMDATA value for these configurations.

The method to calculating is in adaptation guide. There is 28~24 bit field table. Please take odmdata in config #1~3 as example, and you will know how to calculate it.

I don’t really understand the first sentence, “I successfully flashed it as the USB ports seem to be offline. I thought they only will have less lanes, so USB 2 speed”. What does that mean??

Seems that something went wrong during flash as no configuration has an USB port enabled. I’ve set ODMDATA back to 0x1090000 but even a keyboard is not working on the USB port. What went wrong? Any ideas?

werbenirvana,

I guess your device tree of usb setting has something wrong. Please paste the result of “dmesg |grep xhci”

Please also look at this thread.

https://devtalk.nvidia.com/default/topic/1001771/jetson-tx2/no-usb-support-on-custom-base-carrier-board/

I’ve found out that the PC is not able to flash the board (Ubuntu 16). Flashing with a different PC (Ubuntu 14) works. I’ve used the same installer and installed it twice. I have no idea why the Ubuntu 16 PC cannot flash is. It also takes ~1h to flash, this is also unusual. I mark this thread as solved and accept the first answer as this is the solution to the original question.

OliverUr,

Ubuntu16 is supported after Jetpack3.2. As previous like Jetpack3.1 or Jetpack3.0, we only support 14.04 host.

Are you using Jetpack3.1?

I tried JetPack-L4T-3.2-linux-x64_b157.run and JetPack-L4T-3.2-linux-x64_b196.run.

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.4 LTS
Release: 16.04
Codename: xenial

It’s a fresh installation especially for the Jetson. Unfortunately I don’t know where to start investigating this but sooner or later I need that PC for development.

OliverUr,

Could you share where the installation stuck?(1 hr flash) There must have some points causing hang.