Installing OptiX 9.0 (urgent)

Hello everyone,

I would like to update my optiX version to 3.9. I went through the link to download optiX for windows, but in the end it redirects me to the page says " Access Denied" . How can I solve this problem?

Thank you.

Try this:

  • Go to https://developer.nvidia.com/
  • Log in in the top right corner with your developer.nvidia.com account.
  • Click on “DesignWorks” in the top menu bar.
  • Click on the “OptiX” link.
  • Click on the “Get OptiX” button which leads to the download site of the newest stable release.
  • Bad timing spoiler alert. ;-) Currently it’s too new and doesn’t seem to be live, yet.
  • Instead scroll down to the very bottom of that site and click the “OptiX Downloads” link which leads to a site with multiple OptiX versions.
  • Now pick the third version on that site which is “OptiX 3.9”. That’s OptiX 3.9.0 you wanted and downloading that should work.

Thank you so much for your response, I have one more question:

Can I run my optix 3.8 version code in this new version of optiX?

Yes, the OptiX API remained upwards compatible.
A recompile of your application with the new OptiX version should be all that’s needed.

The release notes contain the list of changes in the “Enhancements” section on the download site.
For example new in 3.9 are some additional API functions for the buffer access of mipmapped, layered, and cubemap textures.

Thank you so much