Installing wine on Jetson Nano

Right now I’m trying to install Wine so it will run with Metatrader 5. Following messages come up:

pc1@pc1-desktop:~$ sudo apt-get install --install-recommends winehq-stable
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package winehq-stable

Please help regard this thanks.

Have you confirmed the winehq-stable is able to support and run on arm system?
I can’t find the compatible version.

This post mentions getting running MetaTrader 4 for Windows x86 in Linux with ARM CPU.

But when I actually tried it myself on Jetson Nano, it did not work. This is how to install wine and windbind:

sudo apt -y install wine-development winbind

And when I tried to run MetaTrader installer, I got the error:

0009:err:process:create_process L"F:\\home\\lissanro\\Downloads\\icmarkets5setup.exe" not supported on this installation (x86_64 binary)
wine: Bad EXE format for F:\home\lissanro\Downloads\icmarkets5setup.exe

The same thing happens with x86 binary:

0009:err:process:create_process L"F:\\home\\lissanro\\Downloads\\icmarkets4setup.exe" not supported on this installation (x86 binary)
wine: Bad EXE format for F:\home\lissanro\Downloads\icmarkets4setup.exe.

This is expected, to be honest I was surprised that the author of the article was able to run it that simple. Either Raspberry Pi comes with special version of Wine with built-in emulation (but the author did not mention this and claimed it should work on any ARM platform) or the post linked above is fake.

Here is another post which describes steps how to get x86 emulation working for Wine, this post is Raspberry Pi specific but it can be used as reference to achieve something similar on Jetson Nano:

It is not going to be easy though. To make things more complicated, MetaTrader 5 is usually offered as x86_64 executable, so x86 emulation is not going to be enough.

So this is from Metatrader 5 website. It’s instruction to install on Linux instead of Ubuntu, but it seems like it’s the same thing.

MetaTrader works fine in Linux/Ubuntu with amd64 CPU, the issue is to install and run it in Linux with arm64 CPU. It is completely different CPU architecture, and as far as I know there is no MetaTrader build for arm64 version of Windows, so it will not run with just Wine alone on Jetson Nano, it needs amd64 emulation. There is also a possibility to get ARM version of Windows running in qemu, it includes amd64 emulation: Introducing x64 emulation in preview for Windows 10 on ARM PCs to the Windows Insider Program | Windows Insider Blog. I did not test it myself, but here you can find more information how to get ARM version of Windows working in Jetson Nano with qemu if you decide to go this route:

Another way, is to use qemu to run amd64 chroot Linux environment with Wine, and use that to run MetaTrader (I already provided a link in the previous post to a tutorial which describes how to achieve this, but you need amd64 emulation instead of x86 if you want to run MetaTrader 5). This way may consume less RAM than running whole Windows just to run MetaTrader.

I run into this. I don’t know if any helpful. I’m trying this today.

If it does work, I’ll run it with Kubernete MS Azure DevOP, along with TensorFlow. Wish me luck.

Since the description does not mention anything about amd64 emulation on ARM platform, it probably will not run on Jetson Nano. However, if you setup amd64 chroot with qemu first, and then run the container there, it may work.

Hi Lissanro, can you show me how to setup amd64 chroot with qemu? Thank you.

I really need help with this. If anybody can help please do thank you. I try to install wine/wine32 but it doesn’t install. When I type ‘yes’ under the last command a infinite vertical column of ‘y’ comes up. Please help thanks.

When I try sudo apt-get wine32 following happens:

Nano don’t have correct CPU architecture to use Wine with just installing it. You can try to run it using armhf chroot and box86 or qemu and i386/amd64 chroot. First option is faster, but less stable and compatible so metatrader may crash, second one is slower.

Thank you for replying Maciek. I’ve tried qemu but it doesn’t work.


when I type ‘yes’ after prompt following happens

when I type sudo apt-get install qemu this happens:

please help thanks.