Integrated CUDA profilers not installed

I have NVIDIA GeForce RTX 3090 and my driver version is 531.30. I tried installing CUDA toolkit 12.1, the Integrated CUDA profilers were not installed. Then I uninstalled CUDA toolkit 12.1 and tried installing CUDA toolkit 11.7, the Integrated CUDA profilers were still not installed. I opened VS2022 and the trace button was grayed out in Nsight System so that I couldn’t use the profiler at all. Do you know what could have went wrong here?

Thanks for reaching out. Is this still an issue? I see in another post that you had an issue with Visual Studio but did a reinstall that fixed it. I’m wondering how VS looks now with respect to profiling. Do you see Nsight Systems and Nsight Compute integation?

It’s solved.

Make sure that you have the latest compatible graphic drivers installed for your NVIDIA GPU. outdated or incompatible drivers can cause issues with the CUDA profiling tools. Visit their website or use the NVDIA getforce experience software to update your graphic drivers.

Hey, Could you share how to solve this problem? Because it also happens to me

  1. Uninstall everything from CUDA toolkit 12.1 package.
  2. Download nsight_visual_studio_edition-windows-x86_64-2023.1.0.23044_32445501 standalone and install it.
  3. Install cuda_12.1.1_531.14_windows, choose customize and uncheck Nsight VSE, install all the other components.
1 Like