Internal compiler error

Having obtained a trial license for PGI Visual Fortran today, I set about trying to compile my project which so far has been developed using the Intel compiler. Just using the default options for building a 32-bit DLL, pretty much everything has worked first time except for one rather ominous error:

classes.f90(155) : error S0000 : Internal compiler error. getsname: bad stype for 0

In my project, “classes.f90” is, as the name suggests, a file containing my various derived types, and line 155 of it is actually blank.

Where do I go from here?


Hi Stephen,

Support for F2003 Classes is still very new, so this is most a compiler bug. In looking through our issue tracking system, I do see the same error was found internally by our QA department and fixed in the 10.6 release. If you are using an earlier version, can you please try our newest version 10.8?

Otherwise if you could, please send a reproducing example to PGI Customer Support ( so we can get this issue fixed.


I’m using 10.8, but I’ll gladly submit an example.


Thanks Stephen,

Customer service sent me code and I was able to reproduce the error with 10.8. The good news is that it we had recently found and fixed this error internally with the fix expected to be available in September’s 10.9 release.

We do apologize for the inconvenience.

Best Regards,