Internal: cudaGetDevice() failed. Status: CUDA driver version is insufficient for CUDA runtime version

2018-05-05 10:50:38.479360: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1423] Adding visible gpu devices: 0
2018-05-05 10:50:38.479663: E tensorflow/core/common_runtime/direct_session.cc:167] Internal: cudaGetDevice() failed. Status: CUDA driver version is insufficient for CUDA runtime version

I install CUDA9.0 on my TX2 with Jetpack3.2 and install tensorflow1.7 with a ‘.whl’ file

Need Help. If anything else need, feel free to comment.

Hi,

Suppose the wheel you installed is not built with CUDA 9.0.

For JetPack 3.2, we have a pre-built file for TensorFlow 1.7 here:
https://devtalk.nvidia.com/default/topic/1031300/jetson-tx2/tensorflow-1-7-wheel-with-jetpack-3-2-/post/5246603/#5246603

Thanks.