Internal debugger error when debugging with NSight


While trying to debug a random crash using NSight’s CUDA Memory Checker I saw the following error

Internal debugger error occurred while attempting to launch _Z24APMConstructIndexedSmallILi19EEvN8bvhtools18APMConstructParamsE in CUcontext 0x2bffebf7ab0, CUmodule 0x2bf8a1e6230:
code patching failed for unknown reason.
All breakpoints for function _Z24APMConstructIndexedSmallILi19EEvN8bvhtools18APMConstructParamsE have been removed.
See Output View for additional messages of this type.

The error seems to be BVH and TrBVH related, but SBVH doesn’t have it. I guess either I’m lucky with SBVH or SBVH doesn’t use that part of the code.

I’ve tried reproducing the error in the OptiX SDK samples and optixMeshViewer gives the same error.

I’m not entirely sure if this is an actual OptiX bug to be worried about, if it’s just a problem for NSight and can be skipped, and if skipable is NSight still usable after the error has happened.


Usual info
GeForce GTX 960M / GeForce 1050
Windows 10 (1703)
CUDA 8.0
OptiX 4.1.1
Driver 385.69 / 388.00
NSight 5.4

Moving this “internal debugger error” case to the NSight Visual Studio forum.