Invalid Checksum - Fedora 19 x64

I’ve run the installer, rpm and the .run installer.

With the RPM everything went fine, except instead of installing the toolkit it reported that the install was successful but all it did was create empty directories. Except for CUDA Samples, which seem to have installed correctly.

so, I decided to try the .run installer.

I immediately get archive errors - “gzip: stdin: invalid compressed data–crc error” - and then the toolkit installation fails (samples install fine). Then I tried extracted the individual installers and running the toolkit install alone.


Error in MD5 checksums: 494b2b1229900657f61ced3024c1a59c is different from e977bce618a5aa772427e91dd8db19a7

I tried redownloading the .run installer and I get the same error.

Am I doing something wrong? or does the download simply keep failing?

I would suggest checking whether you have enough disk space, both for the raw installation file and the files generated during installation (e.g. /tmp). If lack of disk space causes a file to become truncated, that would explain the checksum mismatch. In general you would want to have a minimum of 1 GB available for the installation package itself prior to unpacking, and several times that during installation

Sphenik, can you provide the exact commands used to install the RPM as well as the .run file installations? Yum should let you know if you’re lacking disk space, the .run file provides fewer checks for disk space.

Also, were the empty directories before or after uninstallation?

Another thing that would be helpful is the output of df -h.

I currently have 52.2 GB free in my /home and 24.9 GB free in /. I set the install path to /opt/cuda and I also tried with the default install path.

The RPM did not report any errors for installation. I did have to disable RPMFusion repos in order to do the install because of RPMFusion containing updated packages for the bundled nvidia driver. The empty directories (I assume) were created during installation, as they were deleted after I ran a yum remove.

df -h Output:

Filesystem Size Used Avail Use% Mounted on
/dev/sda3 51G 25G 24G 52% /
devtmpfs 1.9G 0 1.9G 0% /dev
tmpfs 2.0G 1.7M 2.0G 1% /dev/shm
tmpfs 2.0G 1020K 2.0G 1% /run
tmpfs 2.0G 0 2.0G 0% /sys/fs/cgroup
tmpfs 2.0G 752K 2.0G 1% /tmp
/dev/sda1 969M 113M 790M 13% /boot
/dev/sdc1 459G 387G 49G 89% /home
/dev/sdb3 50G 33G 15G 70% /run/media/sphenik/0c2dbcca-3669-4dbb-85f1-0b95a181b4c2
/dev/sdb2 409G 339G 49G 88% /run/media/sphenik/99c2ba0c-ca1b-495d-9e6c-7f925300a035
/dev/sdd1 294G 213G 66G 77% /run/media/sphenik/d86726cf-a0c6-4402-a3af-6cd57b9f09fd
/dev/sdb1 477M 2.3M 445M 1% /run/media/sphenik/89f980d0-be16-49cd-bf9b-9a96554efaac

Thank You for the help, this is my first time trying to install cuda.

Thanks for the output. For .run file installation, you may need more space in your /tmp directory - the installer is pretty greedy with the /tmp space. Try running the .run file with the --tmpdir flag:
sh --tmpdir /home/myname/tmp
to tell it to use a different tmp directory.

Make sure that --tmpdir has a space between itself and the value, and that it is the first option that’s passed.

I’m very curious as to what happened during the RPM install. If you do attempt it again, please take note of the output and the exact commands used to install it.

Thanks AndyDick, I decided to go with the .run installer so I didn’t have to disable the RPMFusion repos again and so I didn’t have to install an earlier version of the graphics driver. The -tmpdir flag solved my problem and so far the toolkit seems to be working properly.

I have extremely slow internet that is shared. Maybe when the line is cleared up I’ll attempt the RPM install and report back here.