Is there a way to turn Physics off for an object after it hits the ground?

Today I learned how to make a plane with holes in Blender and export it to Omniverse.

I then created 10,500 spheres to fall through the holes. My FPS drops to .27, that is roughly 1 frame every 4 seconds.

One way I can think of to improve performance if it is possible, is if there was an option to turn off physics when object stops moving or if it goes past a certain threshold of X, Y, or Z.

Instancing doesn’t seem to help.

Any other tips for how to improve performance on large amounts of objects are welcome.


did you try to use flatcache extension? (Enable omni.physx.flatcache extension).

Another tip on a PhysicsScene in advanced settings set Asynchronous simulation mode.

You can add a plane at some position and increase the sleeping threshold for the bodies so that once they hit the plane they go very soon to sleep.

How do you set the sleeping threshold?

No I didn’t try to use the flat cache, I don’t think. I will look.


Flat Cache and the Asynchronous mode made a huge difference.

With 3,000 spheres I still get almost 70 FPS. Thank you very much.

Cool, on a rigid body you can set the sleep threshold parameter.

1 Like