Omniverse Create animations and physics solving at different time steps

I am having an issue with physics in create. There are some bodies with colliders that have animations prescribed to them and also some rigid bodies with colliders that are bouncing around. This complicated physics simulation is exceeding real time performance. The animated objects in the scene proceed at real time while the physics objects lag behind due to the solver rate. What ends up happening is the animated objects move too fast relative to the physics objects which get left behind.

So, how do we get the physics and the animations to operate in lock-step? So if one slows down due to performance, the other will slow down accordingly.

Thanks for all the help!

first of all do you set the kinematic body on the animated bodies? That should make sure that the movement of the bodies is treated correctly on physics side.

Now if your FPS is tanked physics starts to discard frames, you can set the minimum frame rate in Window->Simulation->Settings to some low value like 1, then physics should not drop frames.

1 Like

Another way is to lock the UI thread FPS to fixed rate and lower it to something like 60fps:

1 Like

Thank you for the quick help with this Ales! I will give these things a try and let you know how it goes.