Unprecise physics - rolling sphere

I have a mesh exported from blender with a flat surface. I put it into a scene and tilt it a couple of degrees, give it a collider and place a sphere with a collider on top. My expectation is that the sphere rolls smoothly down the surface of the shape. The actual result is that the sphere starts jumping.

This does not happen when I increase time steps/second in the physics scene, but doing this degrades performance too much.

Any help appreciated

I am adding a simplified experiment to show the same behaviour. I am using a cube which I have loopcut in Blender to have vertical intersections. I tilt the cube and use its upper face as a plane for a sphere to roll on. I duplicate the cube and rotate it by 90 degrees to do a side by side test with a sphere rolling in parallel to the intersections.

cube_loopcut.usdc (31.0 KB)

Unfortunately this behaviour is currently a showstopper for the simulation I am trying to do, because I try to have a vehicle drive on a surface created in Blender in a similar way.

Is unchecking “Enabled GPU Dynamics” in the physx scene and setting “Broadphase Type” to “MBP” an option?
I’ve asked the physx team if there are any additional settings that can help. But switching to CPU physx might be a simple workaround for now

Disabling GPU Dynamics alone helps in this case.

I have to check other scenarios as well.

Will this influence performance of the simulation a lot?

If you have a small simulation with a few robots/rigid bodies, CPU will be faster. For larger scenes the GPU solver will be more efficient.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.