[Isaac 2022.2, standalone] Simulation getting paused immediately after start

Hi! I am trying to migrate my app on the new Isaac version. However, I am experiencing issues with this, as the app will immediately get paused by sth.

The main loop code is roughly as this:

while self.simulation_app.is_running() and not self.end_condition():
            self.world.step(render=True, step_sim=True) # execute one physics step and one rendering step
            if self.world.is_playing():
                self.run_step()

As a workaround I found out that if I run self.world._timeline.play() after the the step, the simulation will keep on running. Otherwise it stops and nothing happens. Do you perhaps know where the issue could be hiding? Something must have changed in the implementation of the timeline.

Thank you!

@melecky can you modify this script to reproduce the issue?

from omni.isaac.kit import SimulationApp

simulation_app = SimulationApp()

import omni
from omni.isaac.core import World

simulation_app.update()
omni.usd.get_context().new_stage()
simulation_app.update()


world = World()
world.play()
print("Is Playing:", world.is_playing())
world.step(render=True, step_sim=True)
print("Is Playing:", world.is_playing())

assert(world.is_playing() is True)

simulation_app.close()

I have been playing with this but could not find what is causing it so far. For now I am happy with the workaround of manually invoking self.world._timeline.play(). Does it have some large performance impacts?

OK, I found the issue. It was due to this line in the imports: carb.settings.get_settings().set("/omni/replicator/RTSubframes", 32)
I am not sure if this line is still needed, I used it while fixing the quality of images produced by replicator. However, I think I fixed it some other way and forgot to remove this line.