Isaac Sim and Matlab integration

Hello all!

I’ve been trying to figure this out for a while now and probably should have solved this issue im having integrating MATLAB with isaac sim through ROS2 foxy.
I’ve been following this tutorial very closely Set Up and Connect to NVIDIA Isaac Sim - MATLAB & Simulink

I have ROS2 foxy successfully on my machine and you will see in the screen record video attached. Near the end i show that foxy was launched from the guided command prompt. Now when I launch the isaac-sim.bat from the same command prompt, it says ROS2 extentions are missing when I try to activate the extention, but it works normally when I launch it from the omniverse launcher. I’m just not sure what I’m missing here or if I did the wrong input for the FASTRTPS_DEFAULT_PROFILES_FILE. But I cant seem to connect and control the turtle bot in the isaac sim. If someone has some advice, it would be appreciated.

Granted I’m relatively new, not a super experienced programmer as a mechanical grad student, but eager to learn this software.

Hi,

For better visibility, I am moving your topic to the Isaac Sim category.

Raffaello

1 Like


I tried this solution ROS 2 bridge issue
I can successfully have a talker and a listener

2nd screenshot is after trying to call the library before starting isaac sim.

I set the set FASTRTPS_DEFAULT_PROFILES_FILE to fastdds.xml from a workaround provided by NVIDIA I just am not sure where im going wrong and would appreciate someones input

this was the fast dds file i used

I am pleased to mention, it has been rectified. I tried all workarounds for ROS foxy and did not work. Reached out to MATLAB for support. and 2023B ROS toolbox works with ROS humble, ROS2 foxy is not supported anymore. I got all of the packages for ROS2 humble and was pleasantly surprised with the seamless integration. For those that appear from the MATLAB issac sim tutorial, USE HUMBLE!!!