Isaac Sim Python App Not Caching Shaders, Waiting for compilation of ray tracing shaders for RTX renderer

I am using python.bat to run custom scripts. Every time it is ran, it takes over two minutes to start the actual python script. It always waits at “Simulation App Starting”, then finally finishes.

This can be tested by running ./omni.isaac.sim.warmup.bat in the root of the Isaac Sim folder, (%userprofile%\Appdata\Local\ov\pkg\isaac_sim-2023.1.0-hotfix.1). Hello World! does show up and so does “Python app shader cache is warmed up.”

In the log that is from the original warmup right after install, (attached kit_20231211_145855.log) it says:
“Waiting for compilation of ray tracing shaders for RTX renderer main raytracing pipeline by GPU driver:” then counts up in seconds by 30 second intervals.
I run ./omni.isaac.sim.warmup.bat once and same “Waiting for compilation…” and over two minutes later it finishes.
I run again, (omni.isaac.sim.warmup.bat) and the same “Waiting for compilation of ray tracing shaders for RTX renderer” occurs, 120 seconds, (attached kit_20231211_152717.log). I can run Isaac Sim through the launcher and it does not take a long time to load.

This issue is the same on another two of my machines, (Windows 11, RTX 3090, 64 GB and Windows 11 RTX 2060, 16GB ram). This happened with 2023.1.0, (not hotfix) as well.

These are the steps that I took to try to fix. However I still have this issue. And the logs are after this “clean” install.

  1. uninstalled Isaac Sim, (both hot fix and non hotfix) via Omniverse Launcher
  2. uninstalled Cache via Omniverse Launcher
  3. now nothing is installed in the Omniverse launcher
  4. deleted everything in %userprofile%\AppData\Local\ov\cache from Setup FAQ — Omniverse IsaacSim latest documentation. Is there another cache folder I should delete?
  5. re installed latest Nvidia graphics driver 537.99-quadro-rtx-desktop-notebook-win10-win11-64bit-international-dch-whql.exe
  6. reboot
  7. installed Cache 2023.1.0
  8. installed Isaac Sim 2023.1.0-hotfix.1

On the brand new install omni.isaac.sim.post.install.run.bat runs but does not complete, (I waited 20 minutes). output is:

"Isaac Sim Post-Installation Script"
Warming up shader cache... Please wait...
Close this window to skip.
Isaac Sim Post-Installation Script completed!
The process cannot access the file because it is being used by another process.

Windows 11
Omniverse Launcher 1.9.8
Cache 2023.1.0
Isaac Sim 2023.1.0-hotfix.1

64 GB Ram
3.45TB free of 3.72 TB Hard Drive
RTX Ada 6000
Nvidia driver 537.99
kit_20231211_145855.log (807.3 KB)
kit_20231211_152717.log (785.2 KB)
omni.isaac.sim.post.install.log (51.6 KB)

I solved this by adding --vulkan to the python.bat command line:
./python.bat my_script.py --vulkan
I remembered that adding --vulkan was suggested for a solution but can recall where I saw this or what exactly --vulkan does.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.