[Issue] The fan on Jetson TX2 will drive up to maximum speed after installing ZED camera ROS wrapper

Hi everyone,

I was playing the Jetson TX2 with ZED camera and running ROS Kinetic on Ubuntu 16.04.
I followed the instruction from ZED website (https://www.stereolabs.com/docs/ros/) to install the ROS package and device driver for ZED camera.

Issue:
After installing the ZED camera ROS wrapper, the fan on Jetson TX2 will drive up to maximum speed every time the Jetson TX2 is powered on.

Attempts:
1.
I tried the following command and it can calm down the fan for a while.

sudo ./jetson_clocks.sh

It is 0 in the /sys/kernel/debug/tegra_fan/target_pwm.

However, the fan will drive up to maximum speed after few seconds or minutes.
It is 255 again in the /sys/kernel/debug/tegra_fan/target_pwm.

I also tried to change the fan pwm manually by the following command

sudo gedit /sys/kernel/debug/tegra_fan/target_pwm

It is 255 in the /sys/kernel/debug/tegra_fan/target_pwm.

I replaced the 255 with 0 and saved it.
It is 0 in the /sys/kernel/debug/tegra_fan/target_pwm.

However, the fan will drive up to maximum speed after few seconds or minutes.
It is 255 again in the /sys/kernel/debug/tegra_fan/target_pwm.

Guess:
I guess there might be some background script is running to overwrite the sys/kernel/debug/tegra_fan/target_pwm with 255.

Have anyone encounter the same problem?
Any thoughts?

Thank you in advance,
Luke

I have seen this on Xavier. The ZED sdk had a copy of jetson_clocks.sh located in /usr/local/zed/tools and this script was called from /etc/rc.local after 60 seconds. You may try to comment it there, and you may have to start it manually if what you’re doing with your ZED can’t be done with your current clock settings.

Hi everyone,

I got the response from Stereolabs Support and my issue is gone!
Here is part of the email explaining the reason how to handle it.

“”"
The ZED SDK installer gives you the possibility to set the Jetson in maximum performance mode.
This makes sure the Jetson is ready to run the ZED SDK and your programs at the maximum of its capabilities.

To disable this, you can run

systemctl disable jetson_clocks

and reboot.

“”"

I ran the single line command and my world become peace again…
Thank you!

Hi ljcikc,
Have you ever meet any auto shutdown problem with your TX2?
I installed jp4.2 + ROS melodic and the lastest wrap plug, and met the problem in https://devtalk.nvidia.com/default/topic/1055303/jetson-tx2/tx2-dev-kit-always-loss-power-few-minutes-after-startup/

It’s still doubtful to say the jetson_clock.service cause system crash I think.

Thank you in advance.