Issue with TensorRT binary

Description

Hi,
I am trying to run sample_dnn_tensor and I am facing the following issue:

Environment

a. OS : Nvidia Drive OS 5.2.0
b. Driverworks version : 3.5
c. Board : Custom board
d. Test application : sample_dnn_tensor
e. Execution command : ./sample_dnn_tensor --video=/usr/local/driveworks-3.5/data/samples/recordings/suburb0/video_0_roof_front_120_short.h264 --tensorRT_model=/usr/local/driveworks-3.5/data/samples/detector/volta-integrated/tensorRT_model.bin
f. Result (This case is working in Drive AGX e3550 and make expected output.)

Relevant Files

Please attach or include links to any models, data, files, or scripts necessary to reproduce your issue. (Github repo, Google Drive, Dropbox, etc.)

Error

nvidia@tegra-ubuntu:/usr/local/driveworks-3.5/bin$ ./sample_dnn_tensor --video=/usr/local/driveworks-3.5/data/samples/recordings/suburb0/video_0_roof_front_120_short.h264 --tensorRT_model=/usr/local/driveworks-3.5/data/samples/detector/volta-integrated/tensorRT_model.bin

[23-03-2021 14:56:31] Platform: Detected DDPX - Tegra A

[23-03-2021 14:56:31] TimeSource: monotonic epoch time offset is 1616506788195357

[23-03-2021 14:56:31] TimeSource: Could not detect valid PTP time source at nvpps. Fallback to eth0

[23-03-2021 14:56:31] TimeSource Eth: Lost PTP time synchronizaton. Synchronized time will not be available from this timesource.

[23-03-2021 14:56:31] TimeSource: Could not detect valid PTP time source at ‘eth0’. Fallback to CLOCK_MONOTONIC.

[23-03-2021 14:56:31] Platform: number of GPU devices detected 1

[23-03-2021 14:56:31] Platform: currently selected GPU device integrated ID 0

[23-03-2021 14:56:31] Context::getDataPathFromSelfLocation DATA_ROOT found at: /usr/local/driveworks-3.5/data

[23-03-2021 14:56:31] SDK: No resources(.pak) mounted, some modules will not function properly

[23-03-2021 14:56:31] SDK: Create NvMediaDevice

[23-03-2021 14:56:31] SDK: Create NvMedia2D

[23-03-2021 14:56:31] SDK: use EGL display as provided

[23-03-2021 14:56:31] TimeSource: monotonic epoch time offset is 1616506788195357

[23-03-2021 14:56:31] TimeSource: Could not detect valid PTP time source at nvpps. Fallback to eth0

[23-03-2021 14:56:31] TimeSource Eth: Lost PTP time synchronizaton. Synchronized time will not be available from this timesource.

[23-03-2021 14:56:31] TimeSource: Could not detect valid PTP time source at ‘eth0’. Fallback to CLOCK_MONOTONIC.

[23-03-2021 14:56:31] Initialize DriveWorks SDK v3.5.75

[23-03-2021 14:56:31] Release build with GNU 7.3.1 from heads/buildbrain-branch-0-gc61a9a35bd0 against Drive PDK v5.2.0.0

[23-03-2021 14:56:31] Initialize DriveWorks VisualizationSDK v3.5.75

[23-03-2021 14:56:31] Initialize DriveWorksGL SDK v3.5.75

[23-03-2021 14:56:33] SensorFactory::createSensor() → camera.virtual, camera-group=a,camera-index=0,camera-type=ar0231-rccb-bae-sf3324,input-type=video,offscreen=0,profiling=1,slave=0,tensorRT_model=/usr/local/driveworks-3.5/data/samples/detector/volta-integrated/tensorRT_model.bin,video=/usr/local/driveworks-3.5/data/samples/recordings/suburb0/video_0_roof_front_120_short.h264

[23-03-2021 14:56:33] CameraVirtual: defaulting to non SIPL

[23-03-2021 14:56:33] CameraBase: pool size set to 8

[23-03-2021 14:56:33] CameraVirtualNvMedia: no seek table found at /usr/local/driveworks-3.5/data/samples/recordings/suburb0/video_0_roof_front_120_short.h264.seek, seeking is not available.

SimpleCamera: Camera image: 1920x1208

Camera image with 1920x1208 at 30 FPS

[23-03-2021 14:56:33] StreamConsumerGL: successfully initialized

[23-03-2021 14:56:33] StreamProducerCUDA: successfully initialized

[23-03-2021 14:56:34] INVALID_CONFIG: Using an engine plan file across different models of devices is not recommended and is likely to affect performance or even cause errors.

[23-03-2021 14:56:34] INVALID_CONFIG: Deserialize the cuda engine failed.

[23-03-2021 14:56:34] Driveworks exception thrown: DW_INTERNAL_ERROR: DNN: Unable to load model.

terminate called after throwing an instance of ‘std::runtime_error’

what(): [2021-03-23 14:56:34] DW Error DW_INTERNAL_ERROR executing DW function:

dwDNN_initializeTensorRTFromFile(&m_dnn, tensorRTModel.c_str(), nullptr, DW_PROCESSOR_TYPE_GPU, m_sdk)

at /dvs/git/dirty/gitlab-master_av/dw/sdk/samples/dnn/sample_dnn_tensor/main.cpp:234

Aborted (core dumped)

nvidia@tegra-ubuntu:/usr/local/driveworks-3.5/bin$

Can you please help me with the above error?
Is this error coming from binary file and I have to build .bin file on target platform to avoid the error?
Can you please point me to the documentation for binary?

Thank you.

Hi,
Please check the below link, as they might answer your concerns
https://docs.nvidia.com/deeplearning/tensorrt/api/index.html
Thanks!

Hi @uic73446,

If this is same issue, we request you to use following thread to reply.

Thank you.