Java programs are completely unresponsive (most likely nvidia related)

After upgrading from OpenSuSe 13.2 to OpenSuSe TumbleWeed all GUI Java programs are freezing up (sometimes taking the entire desktop with them).

This is most likely an Nvidia issue as I did this upgrade on my notebook and work machine without any issues (those are both pure Intel machines).

kernel: desktop - 4.0.5-3.2
xorg server: 7.6_1.17.2-1.1
nvidia driver: 352.21
Java: Oracle/OpenJDK (tested several versions)
KDE desktop

EDIT: don’t know if this is related:

[ 1006.010119] QSGRenderThread[2883]: segfault at 98 ip 00007f8c6db35f75 sp 00007f8c457fd760 error 4 in[7f8c6c479000+19fb000]

So it’s definitely NVIDIA related. I downgraded to 346.82 driver and that completely removed the issue.

Eclipse launches for me and so does javafx applications, cannot remember i had issues with java apps. What applications are you trying with?

So unfortunately, while slightly better, even the older version of Nvidia driver has this issue.

I’m running into this issue with Eclipse, Netbeans and Clion (Clion & Eclipse with both OpenJDK/Oracle, Netbeans requires Oracle).

If I run the process in

strace -f

it runs slowly, but doesn’t lock up. It also unlock immediately when

strace -f -p $PID

is attached to the process.

Probably not related then, maybe something else is spooky.

Well, really the only thing that this machine differs from the others (significantly) is the Nvidia GPU.

Try opensource drivers and see if it works then?

Good idea. Will noveau work with a 970?

So Noveau doesn’t work 970 yet, but I have pretty much narrowed it down to a GPU driver problem.

If I run the same programs remotely (remote X) they work just fine.

I have no idea how to confirm it though.