Jertson AGX Orin GPIO doesn't work

Hello,Thank you for reading my topic.

I’m using Jetson AGX Orin in my research.
I’ll be going to use GPIO pins to read inertial sensers data.
I tried to executed a LED blink code below to test my GPIO pins but it didn’t work.
Python didn’t show no error message and LED didn’t blink.

import time
import sys


import Jetson.GPIO as GPIO

pin = 16

GPIO.setup(pin, GPIO.OUT)
GPIO.output(pin, GPIO.HIGH)
GPIO.output(pin, GPIO.LOW)

I checked that the 16 GPIO pin didn’t have voltage with a voltmeter and that 3.3 volt pin worked.

Thank you.

nvidia going to fix in next software release

hello taitai,

this is known issue that GPIO controls did not work with JP-5.0 DP release image.
however, you may have GPIO configuration through pinmux register. please see-also Topic 220249.

hi, afridali123

Thank you for your kind reply.
I understood our situation.
I will wait until next update.

Thank you.

hi, JerryChang

Thank you for your kind reply.

OK. I will check it.

Thanky you

hi, JerryChang

If I uninstall the jetpack 5.0 and install jetpack4.6.1 to Jetson AGX Orin(kernel 5.10) , can I use the GPIO pins?
Does jetpack 4.6.1 support Jetson AGX Orin(kernel 5.10)?

Thank you

no, JetPack-4.6.1 doesn’t support Jetson AGX Orin.

Thank you for your support

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.