Cannot control GPIO pins using /sys/class/gpio

I know that the previous method of GPIO calculation is not valid anymore for K5.10. I reviewed this topic: About the use of Orin GPIO port. I referenced Table 3-4 in the documentation for the 40 pin header of the AGX Orin. These are the steps I followed in attempting to control GPIO pin 22 on my AGX Orin:

sudo su
cat /sys/kernel/debug/gpio | grep PP.04 // Soc GPIO Pin #
gpio-444 (PP.04)

echo 444 > /sys/class/gpio/export
echo out > /sys/class/gpio/PP.04/direction
echo 1 > /sys/class/gpio/PP.04/value

I then monitored voltage at pin 22 using both the ground at pin 6 and pin 20 and in both cases I was unable to read any voltage output from pin 22.

hello wesleygenemyers,

may I know which release version you’re using,
since JetPack SDK 5.0.2 | NVIDIA Developer is available now, could you please moving to the latest release for confirmation,

How do I check my version of Jetpack on the Orin?

hello wesleygenemyers,

here’s commands to check L4T release version on your target. i.e. $ cat /etc/nv_tegra_release
you may also refer to JetPack Archive | NVIDIA Developer, it shows the mapping of JetPack and L4T release.

here is my output:

From referring to the link you provided, this looks like L4T 34.1.1, which is JetPack SDK 5.0.1. Should I flash to the newest version?

hello wesleygenemyers,

l4t-r34.1.1 it is developer preview version, and it’ll deprecated soon.
please moving to JetPack 5.0.2 since it’s the latest production release for Orin series.

I tried flashing JetPack 5.0.2, but after flashing was complete and I get to the part where it is supposed to install SDK components (where the NVIDIA Orin is now booted up on the login screen), my computer no longer detects the NVIDIA Orin and fails to install the SDK components. I have tried flashing twice now with the same results. I have tried reconnect the usb port to every single usb port on my host machine and nothing is working.

hello wesleygenemyers,

may I know the list of installation failed SDK components.

how about install the JetPack image only, and using apt to have post-installation.
please execute $ sudo apt list nvidia-l4t* to review all installed packages on your target,
you may see-also Update Packages for Jetson Devices, please run apt commands to install the package manually.

Hi Jerry,

I actually ended up doing that and everything seems to work. With JetPack 5.0.2, I was able to control pins through command line in the steps I described in the initial post. Thank you so much for you help!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.