JetPack 4.4 - L4T R32.4.3 production release

Hi,

If anyone get system stuck after running OTA update, please refer to this thread.

If we flash jetpack 4.4 on jetson nano then we have to install cuda 10.2 separately or not ?

Just a question regarding DLC because I am trying to update some custom installation scripts. Where can i find the contents of https://developer.nvidia.com/embedded/dlc/ for this release?

Jetpack 4.4 already includes cuda 10.2. So no cuda installation is required.

Jetson Download Center is here:

Is there any way to still do an OTA upgrade to r32.4.2? I am using an OEM carrier board in a sealed box and the only way I can currently upgrade to 4.4 preview is to start with their 4.3 image and upgrade to 4.4 preview.

But doing an OTA upgrade today updates to 4.4 production release. And this seems to imply that the production release of JetPack 4.4 is ONLY compatible with the production release of DeepStream 5.0

JetPack 4.4 supports the upcoming DeepStream 5.0 release

    • DeepStream 5.0 Developer Preview is only supported with JetPack 4.4 Developer Preview.

I upgraded a device today to 4.4 production and now our application which uses Deepstream 5.0 fails.

I tried setting /etc/apt/sources.list.d/nvidia-l4t-apt-source.list to 32.4.2 before doing the upgrade but it fails
Ign:16 https://repo.download.nvidia.com/jetson/common r32.4.2 InRelease
Ign:17 https://repo.download.nvidia.com/jetson/t210 r32.4.2 InRelease
Err:18 https://repo.download.nvidia.com/jetson/common r32.4.2 Release
404 Not Found [IP: 184.150.70.89 443]
Err:19 https://repo.download.nvidia.com/jetson/t210 r32.4.2 Release
404 Not Found [IP: 184.150.70.89 443]
Reading package lists…

Is there some way this can be fixed so we can still upgrade to r32.4.2 instead of r32.4.3

Thanks!

You can still install JetPack 4.4 Developer Preview using SDK Manager. Would that work for your case? APT upgrade to Developer Preview (32.4.2) is not possible anymore since we maintain debian packages per minor releases (32.x) and for 32.4, the debian packages in the server is upgraded to 32.4.3

The device is not an nVidia developer kit. It is a dev kit board on a custom carrier, i haven’t tried using the SDK Manager on this device. Can you just update the OS image without flashing everything via the SDK Manager?

Can I get the debian packages from somewhere else and install it manually?

I am extremely new to all of this.

JetPack 4.4 - L4T R32.4.3 production release
Missing sone cuDNN define .

CUDNN_CONVOLUTION_FWD_SPECIFY_WORKSPACE_LIMIT
CUDNN_CONVOLUTION_BWD_DATA_SPECIFY_WORKSPACE_LIMIT
CUDNN_CONVOLUTION_BWD_FILTER_SPECIFY_WORKSPACE_LIMIT
etc…

And Can’t build Caffe .

src/caffe/layers/cudnn_conv_layer.cpp:482:11: error: ‘CUDNN_CONVOLUTION_FWD_SPECIFY_WORKSPACE_LIMIT’ was not declared in this scope
CUDNN_CONVOLUTION_FWD_SPECIFY_WORKSPACE_LIMIT,

JetPack 4.4 DP - L4T R32.4.2 developer preview has these define and No problem for build Caffe .

@freewing.jp these cuDNN defines and functions were previously marked as deprecated in the cuDNN documentation and now have been removed.

You may want to try building a newer version of caffe or caffe master to see if caffe has been updated to support cuDNN 8.0.

1 Like

Can you please provide me the information how to check cuda install with jetpack 4.4 or not ?
i checked with nvcc -V command but cuda not found so please give me reply

Hey Dusty the new 4.4 ota failed to boot to gui login.
I am able to login to tty shell by pressing alt+F2.
I ran apt update then upgrade but it fails to unpack the l4t 20200625 file.
It is in a temp file so should i try to delete that file and will work to download the new file? I am running Focal Fossa on the OEM Nano. Under /var/cache/apt/archives there are 3 nvidia-l4t-init file one that is now (202004), one that is trying to upgrade (20200625), and one that is 20200709 and i thinck it is a partial file.

Hi @thevividdroid, since JetPack officially supports 18.04, I am not sure about the upgrade procedure for a custom 20.04 installation. You might want to open a new topic about it or re-flashing the device.

Hi @yelei,

I notice now that you are working with jetson-stats, I can help you with some issues or question that you open.

From jetson-stats 2.1.0 and previous to manage the the NVIDIA Jetson I made two different services:

  1. jetson_stats_boot only to start-up the fan in manual mode
  2. jetson_performance to enable and disable jetson_clocks

The first one was sometimes with error, like you have seen in your board.

From next monday I will release a new version of jetson-stats that will fix all this issue and will use now only one service, called now jetson_stats.service

The main feature for this coming version is:

  • no more sudo - Finally you will monitor and control your NVIDIA Jetson without sudo
  • shared memory - You can read now the shared memory used from your GPU
  • fan control - Finally I fixed all issues around the fan, and I hope you will be without anymore issues

If you have any other issues do no hesitate to write me or open an issue directly in my repository https://github.com/rbonghi/jetson_stats

3 Likes

The new version of jetson-stats is out! The release 3.0 ha completely rearrange the package improved the API and more, without write here a long message I will attach a link with all information https://github.com/rbonghi/jetson_stats/releases/tag/3.0.0

To update jetson-stats: sudo -H pip install -U jetson-stats (This update will need a logout or reboot)

jtop

4 Likes

Well I abandoned trying to fix the crashed 4.3 upgrade to L4T 4.4 OTA. I downed the new Jetpack Image and flash to a 32 G card and now it hangs at the Nvidia logo. Wtfrack, anybodyelse having these issues?

I release this morning a fix for jetson-stats to decrease the computational speed for jetson nano and jetson_clocks. (other fixes are here https://github.com/rbonghi/jetson_stats/pull/74)

To update: sudo -H pip install -U jetson-stats

For any issue do not hesitate to write me

1 Like

Never mind, forgot to reboot. Maybe adding that to your latest post would have avoided my mistake.

1 Like

I was writing to reboot your board! :-) Next time open an issue on my repository https://github.com/rbonghi/jetson_stats/issues

It is easily for me to collect all this information

2 Likes