Jetpack Tegra Multimedia Samples Don't Work

I have just updated to JetPack 3.1. All went well according the jetpack installer. I wanted to try out some samples. I went to the readme and the instructions are no longer there they have been moved to https://developer.nvidia.com/embedded/downloads where I have to login and download this tar file: Tegra_Multimedia_API_R24.2.2_aarch64.tbz2. I did that.

I tried sample 12 (12_camera_v4l2_cuda) using the options shown in the readme:
./camera_v4l2_cuda -d /dev/video0 -s 1280x720 -f YUYV -c

I get the following output:
ERROR: camera_initialize(): (line:238) Failed to set camera output format: Invalid argument (22)
ERROR: init_components(): (line:336) Failed to initialize camera device
ERROR: main(): (line:718) Failed to initialize v4l2 components
App run failed

I have no idea what the problem could be. I didn’t have a problem in JetPack 3.0

Next I tried the real-time inference example:
./backend 1 …/…/data/video/sample_outdoor_car_1080p_10fps.h264 H264
–gie-deployfile …/…/data/model/GoogleNet-modified.prototxt
–gie-modelfile …/…/data/model/GoogleNet-modified-online_iter_30000.caffemodel
–gie-forcefp32 0 --gie-proc-interval 1 -fps 10

I get the following output:
Error: Unknown option --gie-deployfile

backend … [options]

Channel-num:
1-4, Number of file arguments should exactly match the number of channels specified

Supported formats:
H264
H265

OPTIONS:
-h,–help Prints this text
-fps Display rate in frames per second [Default = 30]

--s                  Give a statistic of each channel
--input-nalu         Input to the decoder will be nal units[Default]
--input-chunks       Input to the decoder will be a chunk of bytes

--trt-deployfile     set deploy file name
--trt-modelfile      set model file name
--trt-proc-interval  set process interval, 1 frame will be process every trt-proc-interval
--trt-forcefp32      0 to use fp16 (if supported), 1 to use fp32
--trt-dumpresult     1 to dump result, 0[default] otherwise
--trt-enable-perf    1[default] to enable perf measurement, 0 otherwise

Why is that? Because the options are different. So, clearly the tgz file I told to download does not match the samples that were loaded by the jetpack installer.

Anybody care to explain why this is so screwed up?

same issue, or nearly

this guy,below link, made a tutorial, at the end, he opens a readme file and copies and pastes a ton of arguments to start-up a demo…you’d think they’d have one that you just click and run, but noooo

and worst yet, the readme file on my install does NOT have the same information, so I can’t run the demo at all - poorly structured for sure

https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=4&cad=rja&uact=8&ved=0ahUKEwjL0o7GqpbXAhUCMyYKHRotBUMQtwIINTAD&url=https%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DD7lkth34rgM&usg=AOvVaw1nIHP9ohcW8qSP7guCbadV

I share the feeling of frustration. As a newbie, I thought the community was biased towards TX1 user (just kidding), since the majority of documents are presented in term of previous generation of silicons.

A bad statement an application engineer would make to his/her customer would be “read the user guide” without pointing to the specific section and page. What even worse is not to say anything at all.

In NVidia community, folks are much nicer. I got a lot of helps here and there. Demo wise, at least I learned to run one demo, oceanFFT.

cd ~/NVIDIA_CUDA-8.0_Samples/bin/aarch64/linux/release
 ./oceanFFT

Hi tslator1,
You should try to install tegra_multimemdia_api via Jetpack3.1.

Tegra_Multimedia_API_R24.2.2_aarch64.tbz2 is for TX1.

12_camera_v4l2_cuda is for USB cameras, not onboard camera ov5693.

As I stated in my initial post, I did install tegra_multimedia_api via Jetpack3.1. In Jetpack 3.0, the README contained instructions for running the demos. Unlikely Jetpack 3.0, the README in Jetpack 3.1 no longer contains these instructions. Instead it points to a URL where the only thing in the related to tegra_multimedia_api is the zip file: Tegra_Multimedia_API_R24.2.2_aarch64.tbz2. I didn’t install the zip file, I only extracted to look at the README.

So, as you say, that zip file is for TX1 which begs the question where is the file for TX2? I don’t care that things change, but it is frustrating that the support for this product is so severely lacking.

With the rant out of way, does anyone know where I can find the Jetpack 3.1 compatible instructions for the tegra_multimetida_api. Thanks.

Please download https://developer.nvidia.com/embedded/dlc/l4t-multimedia-api-reference-28-1