JetRacer: No camera widget when running interactive_regression

Hi,

When I run the interactive_regression notebook on the Orin Nano, I don’t get a camera widget that shows the camera feed, instead it just prints VBOX(…)

When I run the Camera cell, I get a warning that the camera can’t query the video position

I have ipywidgets installed. How can I get the camera feed working in Jupyter Notebook?

The Orin Nano has the GUI enabled currently, and while connected to a display I was able to run all the jetson-inference training examples–including using the live camera feed, so I know the camera works

Hi,

There are two types of cameras.
The API you used is for CSI cameras like Raspberry Pi.
Which type do you use, CSI or USB?

Thanks.

Hi,

I’m using a CSI raspberry pi camera v2 with a wide angle lens (the camera cover is removed when running the notebook)

The same camera can successfully run jetson-inference detectnet to identify objects from a live camera feed, so I’m certain the camera is functioning as expected

When I run nvgstcapture-1.0 when connected to a display, I get a display output

I re-installed ipywidgets using the --upgrade option, and still get the same warning and no camera widget (instead shows VBox(…) text)

Hi,

I made some progress! I uninstalled Jupyter-widgets and the widgets sort of work ¯\_(ツ)_/¯

I have the live camera feed working but I’m getting a javascript error

The error I’m getting is: “Failed to load model class ‘ClickableImageModel’ from module ‘jupyter_clickable_image_widget’”

How do I resolve this error? When I try to install jupyter_clickable_widgets from the source, it says the requirement is already met (source: GitHub - jaybdub/jupyter_clickable_image_widget)

Hi,

The following error seems similar to the link below (although not exactly the same)

Which ipywidgets version do you install?
Could you give v7.7.2 or v7.6.5 a try?

Thanks.

Hi,

I used the below command to install both 7.6.5 & 7.7.2 and they completely break the widgets, instead of showing anything it just shows a rectangle javascript error; only the latest ipywidgets work

sudo pip3 install ipywidgets==7.6.5 --force-reinstall ~/.local/lib/python3.8/site-packages/ --upgrade

Both ipywidgets version 7.6.5 & 7.7.2 result in the below image

I need the ClickableImageModel to work in order to take images of the track to build the dataset that’s used to train the model

The issue is jupyter_clickable_image_widget relies on libraries that are deprecated/no longer used so I don’t know how people will be able to use JetRacer on newer devices if that’s the case

Hi,

I think I know why jupyter_clickable_image_widget doesn’t work–I’m not able to run the following command to install ‘js’ in jupyter lab 4.1.X

jupyter labextension install js

jupyter labextension throws an error saying it needs nodejs version >= 18.0.0 but the latest version of nodejs I can install on the orin is v10.19.0–is there a way to get around this?

I’m also unable to manually import ClickableImageModel running the command

$ python3
>>> from jupyter_clickable_image_widget import ClickableImageModel

I sent an email to Mr. Welsh asking for help getting ClickableImageModel to work, is it possible to contact him over forums?

Hi,

Have you also filed a new issue on the GitHub repo?
They should check the issue list periodically.

Thanks.

Hi,

I created a new issue on the Jupyter Clickable Image Widget GitHub but the last issue posted was back in 2022 and it wasn’t resolved

Hi Venkat,

I made some modifications in my fork and made a PR on the original repo(#10).

I tested on my Orin Nano running JetPack 6.
I’m guessing you are running JetPack 5.x. It would be great if you can test this on your setup.

Hi Cyato,

Thank you so much working on this!

I no longer have access to the Orin Nano (it was part of our senior project and the semester ended a few days ago so we returned everything back to the school)–that being said, another group will be picking up where my team left off in the Fall semester, so I updated my notes that I provided for the next team pointing to your modified fork to resolve the clickable image widget issue

An updated working Jupyter Clickable Image Widget will be great so the road following model can be trained directly on the Orin Nano, which prior to your update was not working

Venkat

Here’s our team’s project summary if anyone is curious, we were able to get JetRacer, variable throttle, object detection (via jetson-inference and mobilenet ssd v2) and avoidance working on our Orin Nano:

https://www.youtube.com/watch?v=-anzSoZteY4