Jetson AGX custom carrier board DP Display issues

I have made a custom carrierboard for the Jetson AGX Xavier. I use DP connector instead of tpye C,I have removed “nvidia,typec-port = /bits/ 8 <0>;” from the dtsi.
Now the boot has a display output, but there is no login screen. The serial port print information is as follows.What’s wrong about it.
log.txt (84.3 KB)

Please also dump dmesg.

dmesg.txt (99.1 KB)

Just want to ask. Do you have other monitors connected?

I use the demo pinmux cfg, but i only use DP1 in my custom carrier board.

You mean I need to disable other display interfaces?

Yes, somehow the HDMI is enabled here and your log is full of HDMI driver log.

[ 1.889728] tegradc 15200000.nvdisplay: hdmi: tmds rate:148351K prod-setting:prod_c_hdmi_111m_223m
[ 1.890402] tegradc 15200000.nvdisplay: hdmi: get RGB quant from REG programmed by BL.
[ 1.890432] tegradc 15200000.nvdisplay: hdmi: BL set VIC 0
[ 1.890476] tegradc 15200000.nvdisplay: hdmi: get YCC quant from REG programmed by BL.
[ 12.137725] tegra-i2c 31c0000.i2c: rx dma timeout txlen:28 rxlen:128
[ 12.137751] tegra-i2c 31c0000.i2c: — register dump for debugging ----
[ 12.137772] tegra-i2c 31c0000.i2c: I2C_CNFG - 0x22c00
[ 12.137789] tegra-i2c 31c0000.i2c: I2C_PACKET_TRANSFER_STATUS - 0x10001
[ 12.137807] tegra-i2c 31c0000.i2c: I2C_FIFO_CONTROL - 0x0
[ 12.137825] tegra-i2c 31c0000.i2c: I2C_FIFO_STATUS - 0x800080
[ 12.137841] tegra-i2c 31c0000.i2c: I2C_MST_FIFO_CONTROL - 0x70
[ 12.137859] tegra-i2c 31c0000.i2c: I2C_MST_FIFO_STATUS - 0x7c0000
[ 12.137876] tegra-i2c 31c0000.i2c: I2C_MST_PACKET_TRANSFER_CNT - 0x0
[ 12.137893] tegra-i2c 31c0000.i2c: I2C_INT_MASK - 0x6c
[ 12.137910] tegra-i2c 31c0000.i2c: I2C_INT_STATUS - 0x2
[ 12.137936] tegra-i2c 31c0000.i2c: i2c transfer timed out addr: 0x50
[ 12.138653] extcon-disp-state external-connection:disp-state: cable 48 state 1
[ 12.138673] Extcon AUX2(HDMI) enable

The main screen by default is the HDMI, so the login screen will be shown on HDMI. However, this does not exist on your board at all.

So please disable those nvdisplay from your dts.

OK,thanks. I will try it again.

I change the pinmux and dts, but it don’t work.
Did I miss something?
tegra194-p2888-0001-p2822-0000-common.dtsi (8.8 KB)

Not sure what you are doing. Not change the pinmux.

Change the nvidisplay status to disabled. Which is the “head” in your device tree.

This is my hardware design,i only use DP1 to display.

Which file do I need to modify and how do I modify it?

Just find out head0 in your device tree, set it status to disabled and your hdmi head will be disabled.