Jetson AGX custom carrier board DisplayPort changes

Hello,
I have a custom carrier board for Jetson AGX Xavier. In this board we use miniDP port with connection to HDMI_DP0_TXx (pins H48-K52).

Based on this I did following steps:

  1. comment lines for sor0 and sor1 (with “nvidia,typec-port = /bits/ 8 <0>;”) in tegra194-p2888-0001-p2822-0000-common.dtsi (in /hardware/nvidia/platform/t19x/galen/kernel-dts/common/);

  2. changed tegra194-p2822-disp.dtsi (in /hardware/nvidia/platform/t19x/galen/kernel-dts/common/) for disable head0 and head2. Do I understand correctly that only head1 with sor0 should remain enable?

  3. power on Jetson module with original carrier board, after booting Ubuntu delete file /boot/extlinux/extlinux.conf.

  4. build new dt (./nvbuild.sh).

  5. copy tegra194-p2888-0001-p2822-0000.dtb from <build_dir>/arch/arm64/boot/dts/nvidia/ to Linux_for_Tegra (directory where flash.sh is located).

  6. setup custom carrier board and load to recovery, after this flashed with cmd: sudo ./flash.sh -r -k kernel-dtb -d tegra194-p2888-0001-p2822-0000.dtb jetson-agx-xavier-devkit mmcblk0p1

After this steps board does not display an image on the monitor. What went wrong?
tegra194-p2822-disp.dtsi (3.1 KB)
tegra194-p2888-0001-p2822-0000-common.dtsi (9.6 KB)
tegra194-p2888-0001-p2822-0000.dts (455.9 KB)

I would suggest you to enable this with jetpack 4 first.

I flashed JetPack 4.6.2, build DT with l4t 32.6.1, boot Ubuntu18 and remove /boot/extlinux/extlinux.conf file. After this I flashed a new dtb and DP still not working. What could I be missing?
dmesg.txt (60.0 KB)

Looks like hotplug is not even detected. Have you checked the pinmux setting?

From schematic the pins of the display port on the Jetson devkit board and on the my custom board are the same. But I made my own version of the pinmux file anyway, replaced the files in the /t186ref/BCT/ folder and flashed the full system - no change. It might be worth trying a different adapter (because we use a mini connector, we have to use an adapter to VGA).

Some update for my issue. We found out that there was a hardware problem on the board - incorrect connection to the DP pins (mixed up). I received a special cable where the pins must be changed to the correct ones. In dmesg, I see that the DP is determined, but there is still no image. Also, the problem may be in the cable itself, because. no one checked it. I am attaching the dmesg with the DP errors and the current DT.
dt-from-fs.dts (358.9 KB)
dmesg251122.txt (124.1 KB)

Try other kind of monitor to test too. The link training fails.