Jetson agx orin SPI2

I modify the spi@3230000 node in the “tegra234-soc-spi.dtsi” file to see if SPI2 can be enabled?

Hi, It looks like you posted in the wrong category. I am moving this topic to the Jetson forums so the support team has visibility.

Hello, this is still a problem that needs to be solved, please arrange to help solve the problem.

Hi Andyyyyy,

Are you using the devkit or custom board for AGX Orin?
What’s you Jetpack version in use?

Hey, KevinFFF, I used a custom board,
I used JetPack_5.1, and I validated most of the hardware interfaces in 5.1. However, debugging of SPI2 failed.

sudo devmem2 0x0c302048 word 0x00000400 
sudo devmem2 0x0c302050 word 0x00000450 
sudo devmem2 0x0c302048 word 0x00000400 
sudo devmem2 0x0c302028 word 0x00000400

sudo modprobe spidev

root@nvidia-agx-orin:/dev# ls | grep spi*
grep: spidev0.1: Message too long
grep: spidev2.0: Message too long
grep: spidev2.1: Message too long

I used these spi to send data and never looked at multiple data waveforms.

Your pinmux seems correct for SPI usage.

Could you help to verify with latest JP5.1.1(R35.3.1)?

Have you tried verify with SPI loopback test?

Yes, I plan to verify JP5.1.1 today and tomorrow!
No, I have not tried to use SPI for loopback test verification, I do not know how to do SPI loopback test.

You could just connect MOSI and MISO together and refer to the following steps for SPI loopback test.
Jetson Nano SPI Bus Not Working - #10 by KevinFFF
It is for Jetson Nano, but I think the overall process for SPI loopback test should be similar.

AGX Orin SPI2 is not spi@3230000.
I can help you if you haven’t solved it yet.

Thank you very much for your help. I have completed the loopback test according to the steps, and I should be able to communicate with SPI externally

1 Like

Hi popoyhyun,
Thank you very much, I have completed the spi communication function.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.