Jetson AGX Xavier not booting properly after flashing Jetpack 5.0.2


I have a Jetson AGX Xavier Module that I was flashing from Jetpack 4.6 to Jetpack 5.0.2 on a Connect Tech Rogue carrier board (AGX111). I tried flashing the device with both Connect Tech’s flashing script and the official Nvidia flashing script (pointing to mmcblk0p1). Both scripts would confirm that the flash was successful, however the boot sequence never finished properly.

When I would boot the AGX nothing would appear on the HDMI display, so I connected to the UART debugger and saw that the UEFI boot manager was running but not being displayed. Later the device start looking for OTA work directories on /dev/mmcblk0p1 which doesn’t seem right to me. Eventually the OTA work directory is not found and it fails to set the proper terminal process group saying
bash: cannot set terminal process group (-1): Inappropriate ioctl for device

A few more messages later and the boot stops, at this point I can hit enter and am inside a minimalist bash shell as root with the host name being bash-5.0.

I was able to narrow down the issue to the AGX module by swapping my module with a college’s AGX module on the same Connect Tech Carrier board. Using the same host computer, carrier board, and the same image I was able to successfully flash and get into the OS on my colleague’s AGX module.

Attached is the output from the UART debugger
uart_debug_output.txt (66.7 KB)


Your log does not help. It is too late.

There is a mechanism in jp5, if your system fails to boot into kernel for consecutive 3 times, then it will enter recovery boot.

Thus, you just shared a recovery boot log which is pointless to check. Everyone’s recovery boot log looks same as yours.
What we should check is the log prior to the recovery boot happened.

Hi Wayne,

I just took another log which starts as soon as I power on the device. I had minicom sitting on the USB port prior to powering the device. However, it still goes straight into the recovery boot and as you mentioned has the same exact boot log. (Attached for verbosity)
uart_cold_boot_log.txt (68.7 KB)

Is there something I must do to force the boot loader to boot normally?

Thank you


I meant you can only reflash your board now. If you don’t reflash it, then reboot it 100 times will always lead to same result as recovery boot.

What we want to see is what happened after your clean reflash.

Hmm it now works…

I just went to reflash the module, using the same method as before with minicom open in another terminal
sudo ./ cti/xavier/rogue/base mmcblk0p1

While in the uart debug terminal I was able to setup the device and was able to login normally.

I haven’t done anything new between today and Friday other than collect that previous log file.

Attached is the uart log while I was flashing and booting up the device just in case it’s still relevant.
uart_log_now_working.txt (80.0 KB)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.