Jetson AGX Xavier Not Starting Out of Box

I just got my Xavier board and I’ve been trying to go through the initial set up per Nvidia’s tutorial, but the Xavier board is almost entirely unresponsive. When I try to boot the board into recovery mode, the white LED comes on, but there is nothing displayed.

I’m using the provided power supply and have tried three different monitors with different resolutions. I’ve tried using the serial debug port, and I can see the 4 devices enumerate and can connect to them, but they don’t output anything, and I can send any commands on anything.

Any ideas? Did I get a lemon board?

The serial console app should allow logging. Can you attach the log of the serial console boot? If you hover your mouse over the quote icon in the upper right of one of your existing posts, then other icons will show up. The paper clip icon allows file attach.

Also, describe if the monitors you tried are pure HDMI or if adapters are involved.

1 Like

From what I can tell the serial port doesn’t output anything. I tried connecting to all four using picocom and powering up the board to see if I can get any output, but no luck.

The first one was HDMI->DVI but the other two I used were pure HDMI.

I am confused by some description here. Have you every flashed your board with sdkamanger?

When I try to boot the board into recovery mode, the white LED comes on, but there is nothing displayed.

By default, there is no HDMI during recovery mode. Thus this sounds not like an error…

Some random information might help…

If you purchased a module, and not a dev kit, then by default it will arrive completely empty and in need of flash.

If you purchased a dev kit, then there should be some initial software already on it.

The serial console port may not show anything if the unit is completely empty.

Recovery mode is not a boot mode so much as it is a way to turn the Xavier into a custom USB device. That device is understood by the driver package flash software which runs on the host PC. When the device is in this custom mode the host PC (via the USB-C) will see the device. This is the test, and if the result is nothing, then the device is either not in recovery mode, or else is not connected via the USB-C:

lsusb -d 0955:7019

Is this a dev kit, or a module using a separately purchased carrier? In recovery mode, and with the USB-C connected, does the above lsusb command show anything?

are you using SDK manager? Jetpack 4.2? Are you using x86_64 Host Computer to flash the device? Or being trying it with “non-Ubuntu” computer, e.g. Mac OSx? Could you extend, please?

Yeah you guys are right. It doesn’t look like there was any real issue. I was thrown off by the set up instructions showing you connecting to hdmi and your peripherals. I knew I still needed to flash it, but in jetpack when you’re in ‘automatic mode’ it says to make sure your Ubuntu OS was up and running on your Xavier and it asked for the IP and log in credentials. I went so far down a rabbit hole trying to get everything working that I didn’t even think to look at the different flash modes. Switching to ‘manual mode’ put me back on track.

Thank you guys so much for helping me out.