Jetson Xavier Agx not booting or changing in recovery mode

today I started my Jetson Xavier Agx and just the fan start spinning and the power led comes on. At the time I started the Jetson only an usc Display, an usb hub and on the GPIO Header CAN0 with 3.3V and GND were connected.
Now I receive no video signals from the jetson.
I am not able to start the recovery mode with holding the recovery button and then power it up or pressing the reset button after pressing the recovery button.
It is not showing up in lsusb nor in the sdk manager when I connect it to the usb c port by the 40pin gpio with my laptop.
Is there a way to test if the mainboard is damaged or am I doing something else wrong?

Hi junior.renzie,

Are you using the devkit or custom board for Xavier AGX?
What’s your Jetpack version in use?

Is there any serial console output after your power up the board? If yes, please provide the log for further check.

I am using the dev board. Right now there is JetPack 5.1 installed.
The Jetson isn’t recognized by my Laptop. Is there another to get the serial output other than connect the jetson via USB?

When I connect a micro USB cable to the debug port I get “Bus 003 Device 003: ID 0403:6011 Future Technology Devices International, Ltd FT4232H Quad HS USB-UART/FIFO IC” in lsusb.
Can i get the serial output via this port?
I installed the OS on a m2 ssd. Is it safe to remove it and start the jetson?

Removing the sd card and m2 ssd didn’t help the problem. I still cannot get the Jetson to boot into recovery mode.

I connected a Micro Usb Cable to the Jetson and started minicom on my Laptop with the command “minicom -D /dev/ttyUSB3 -8 -b 115200”. I also tried the other three USBports but I get no response from the Jetson

Does your board work before?

Could your board boot up or there’s any serial console log output after power up?

Yes. The board worked fine for around two years.
I connected a can transmitter a week ago to the can0 interface. With that change it worked fine. But suddenly a few days ago the jetson didn’t boot anymore.
I couldn’t get any response from the jetson via minicom when I connected it via micro usb to my laptop.

Do you mean that you could capture serial console log before, but there’s no any log output now?
You could refer to the following instruction for capturing serial console log.
NVIDIA Jetson Xavier - Serial Console - RidgeRun Developer Connection

We would need the serial console log to know what happen on the board.
Or have you tried to re-flash the board?
Could it enter into force recovery state and be recognized from your host?

I didn’t test the serial connection with the Jetson before the crash but minicom -D /dev/ttyACM0 -8 -b 115200 works with an arduino. Unfortunately minicom -D /dev/ttyUSB3 -8 -b 115200 shows no output if the Jetson is connected. I followed the guidelines provided in your link.
I tried reflashing with the sdk manager but the Jetson is not recognized by my laptop even if tried changing the Jetson in (force) recovery state.

If it cannot enter into force recovery state nor any log output from serial console, I would suggest you to do RMA for this devkit.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.