Jetson AGX Xavier Usb 3.0,ethernet port is not working , MIPI-CSI Port is not working

@WayneWWW @linuxdev @Dharmalingam.K

Hi Team,

I have a Standard Nvidia Jetson AGX Xavier Developer Kit, suddenly one of my USB 3.0, ethernet ports is not working.

I am also trying to install custom MIPI-CSI Quad cameras from E-Con, which are approved for use on AGX Xavier Developer Kit, which is also not working.

I want to figure out whether this issue is with the Camera or if the Jetson AGX Xavier Developer Kit is faulty.

Please tell me, how to proceed further!

As per the Camera Partner E-con, they have lab tested the cameras and baseboard and found it to be ok.

Flash your board with pure sdkmanager first.

Also, just use rel-32.7.1 version to test.

@WayneWWW should I revert with serial or dmesg log after flashing with 32.7.1?

Yes, preserve them.

Test the etherent and usb functionality first.

@WayneWWW I’ve reflashed with pure SDK manager and tried the latest jetpack release as well, USB and ethernet still do not work. Attaching dmesg log.

dmesg_log_xavier_latest_jetpack (78.5 KB)

Hi,

I was asking for rel-32.7.1. But not some latest jepack5 version.

Please just use 32.7.1 only…

@WayneWWW Even on Rel-32.7.1 , attaching a log for you shortly, I have tried all possible things, but still the ports do not work.

Hi,

I don’t see any log from rel-32.7.1. Did you forget to attach the log?

Sorry . My bad , Please find attached log ethernet and USB are not working.
dmesg_32.7.1 (73.9 KB)

Hi,

I don’t see any activity from ethernet. But I do see something from usb.

[ 5.898725] input: Dell Computer Corp Dell Universal Receiver as /devices/3610000.xhci/usb1/1-1/1-1:1.0/0003:413C:2514.0001/input/input6
[ 5.953019] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 5.956441] hid-generic 0003:413C:2514.0001: input,hidraw0: USB HID v1.11 Keyboard [Dell Computer Corp Dell Universal Receiver] on usb-3610000.xhci-1/input0
[ 5.956587] cgroup: cgroup2: unknown option “nsdelegate”

Are you sure your usb is not working? I don’t think so. We still see something like “Dell Computer Corp Dell Universal Receiver”. This seems to be your device.

@WayneWWW

Current status of Ports :

Internet cable connected to Ethernet Port, Yet Ethernet Port is not working

USB 3.0 Over Power Adapter: Not Working

Other USB 3.0: Used for Flashing is working, I am using a USB 3 port connecting it to the adapter which comes with Jetson AGX Xavier Developer Kit and using it for keyboard and mouse.

Hi,

Please hotplug the usb device to the NG port and see if dmesg on your jetson has anything new got printed or not.

Please just use some basic usb devices (e.g. usb/keyboard) to test.

Hi ,

As I have told you before USB Mouse or USB keyboard do not work on the USB 3.0 Port , this port has become useless , nothing works on it.

But using dmesg --follow , The keyboard usb dongle connect , disconnect is detected , but the usb mouse or keyboard do not work !!

[   97.636413] ucsi_ccg 1-0008: port1 evt: Type-C Port Connect Detected
[   97.638272] ucsi_ccg 1-0008: [typec-port1] Cable state:1, cable id:2
[  100.322717] IPv6: MLD: clamping QRV from 1 to 2!
[  106.261243] IPv6: MLD: clamping QRV from 1 to 2!
[  111.275192] ucsi_ccg 1-0008: port1 evt: Type-C Port Disconnect Detected

Also a Working Ethernet Connection from another AGX Xavier is connected , even that is not working !!

Then please RMA this device. There is nothing I can help.

Does not look like a software issue for usb part.

@WayneWWW

Indian Nvidia Customer Care is refusing to RMA the device as Nvidia Developer Kits Come with 1 Yr Warranty Only and this device is 2 Yrs Old. !!

They showed me the FAQ PAge as well, which says Developer Kits have 1 Yr Warranty !!