Jetson GUI Not displaying on initial start up

Hi
I just received my jetson TK1 today and I followed the steps in the user guide to start it up and run the GUI. Upon reboot, no GUI was displayed instead I got a little dash in the top left corner. It runs through all the text fine but doesnt seem to display the NVIDIA logo or desktop as I have seen on other tutorials.

I have tried different power sources, different HDMI cables, different monitors and even and old VGA display but nothing seems to work. I am currently using a laptop monitor connected directly via HDMI and the 12V barrel power supply supplied in the box.

I am new to the NVIDIA stuff so apologies if this is an easy fix.

Danyon

Hi loud1s,

Not sure what the L4T BSP is on you device, have you tried to flash you device with newest SW?
You could try withe JetPack 3.1 to setup you host PC environment first, then see if need to upgrade to R21.7.

https://developer.nvidia.com/embedded/jetpack-3_1

Hi Kayccc,

How would I try that? do I need to download from the link and save it on an SD card then install it?
I tried running the download commands from the user guide but they didn’t work.

Im very new to this sort of stuff and have only used raspberry pi and arduino before

also tried to download the jetpack but it says I need the SDK which wont open after it has downloaded. Im not sure how to run a .deb file.
I tried ‘sudo dpkg -i /path/to/deb/file’ then ‘sudo apt-get install -f’ but that didnt work

Hi loud1s,

Please use below steps to flash the latest image r21.7 on TK1:

Download package:
-- Driver package: http://developer.nvidia.com/embedded/dlc/tk1-driver-package-r217
-- Root Filesystem: http://developer.nvidia.com/embedded/dlc/sample-root-filesystem-sources-r217
$sudo tar xpf ${L4T_RELEASE_PACKAGE}
$cd Linux_for_Tegra/rootfs/
$sudo tar xpf ../../${SAMPLE_FS_PACKAGE}
$cd ..
$sudo ./apply_binaries.sh
--> Put device into force-recovery mode
$sudo ./flash jetson-tk1 mmcblk0p1

I have tried this and as I was copying the flash over to the Jetson I was met with a 2936 Segmentation fault

Was the segmentation fault from running flash.sh? Or during boot? If it was from flash.sh, can you provide any logs of the moment before the segmentation fault? If it is from boot, do you have a serial console log you can post of the boot? FYI, this is a flash procedure in recovery mode, I’m wondering if you actually mean “copy” or “flash”?

Sorry linuxdev, realised what I typed didnt make much sense.

Turns out I was just impatient in some earlier steps and didnt let things load fully. I got it to work in the end but I was then met with a new error which I was able to solve by running version 21.6 instead of 21.7. Thanks for all your help