Jetson TK1 Detect No GPU

I tried to install the nvidia-smi using “apt-get install” command.
However, it shows me nothing so I uninstall “nvidia-smi”,
and I typed “apt-get remove nvidia-384”.
After that, the system cannot detect the gpu anymore,
even though I tried to reinstall the “nvidia-384”, still not working,
and the GUI is gone.

What should I do to fix this? Do I need to reinstall any kind of drivers?

The software you were trying to use is for a PC, and the hardware is for PCIe-based GPUs. If you are talking about a TK1, then none of that is used on the TK1.

For the TK1 you need to use JetPack to add extra packages such as CUDA. For flash you can just use command line (driver package plus sample rootfs), although JetPack can do this too (JetPack is a front end to command line flash or package additions, but does require an Ubuntu host…command line works with any Linux x86_64 PC host).

The most recent release of L4T (Ubuntu plus hardware accelerated drivers…including the video driver) is R21.7. See:
https://developer.nvidia.com/linux-tegra-r217

Beware that you must log in at that location before you can see the full content. You may need to go to that URL, log in, and then click on the URL again.

If you want to flash on command line, here is a synopsis…be aware that the instructions also mention the TX1 and TX2, and that versions have changed since that was written.
https://devtalk.nvidia.com/default/topic/982779/jetson-tk1/how-to-perform-a-correct-fresh-ubuntu-install-on-jetson-tk1/post/5040584/#5040584

In terms of drivers you won’t need to add any for video after an L4T flash. In terms of using JetPack to install software just uncheck steps and packages you don’t want (JetPack will offer to flash…you don’t have to flash, you can just check to install a package to either PC or Jetson). If you flash, be sure to use the micro-B USB cable. If you add software, be sure to use the wired ethernet cable. Unless you just flashed you’ll need to also manually enter the IP address of the Jetson.