Missing drivers?

Have new Jetson TK1 board. Installed cuda-repo-l4t-r19.1-6-0-rc_6.0-32_armhf.deb.
deviceQuery returns;

deviceQuery Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 38
-> no CUDA-capable device is detected
Result = FAIL

Device appears present;

lspci | grep -i nvidia
00:00.0 PCI bridge: NVIDIA Corporation Device 0e13 (rev a1)

But ‘ls -l /dev | grep nvidia’ returns nothing.
Also ‘ls -l /proc/driver | grep nvidia’ returns nothing.
Also nvidia-smi is not found.

I seem to be missing drivers etc.
What should I do on the Jetson TK1 platform in order to access the GPU?

Thanks,

In hopes that the solution may be helpful to others…
User accounts need to be part of the video group.
The default ubuntu account is in this group but I created unique user accounts that needed to be added to the video group as well.

i’m having same issue. got the jetson kit, installed the driver , nothing. what am i doing wrong? i have different version cuda-repo-ubuntun-l4tr-19.2_6.0-42-armhf.deb. going to try again.

am I correct that jetson kit does not ship with cuda out of the box and we have to install ourselves ?

I am having same problem. It seems that the NVIDIA drivers are missing. Any solution from Nvidia ?

i fixed it. d/l the latest cuda toolkit as i have shown above , make sure to CONNECT TO internet. go through nvidia startup guide for L4T section. add the path variables to .bashrc manually. also simliarly to register or add user ‘ubuntu’ then it went throuhg. make some examples and run it like device query. seems to work for me.

i added the export path for 32 bit library 64 bit, i think tk1 is 32 bit machien not 64 bit . at least not yet

TK1 is 32 bit yes. The next generation K1 which uses the Denver CPU instead of the ARM A15 will be 64 bit. The GPU should remain the same or similar.

http://www.anandtech.com/show/7905/nvidia-announces-jetson-tk1-dev-board-adds-erista-to-tegra-roadmap

I too am having a problem getting the drivers to work.

Pre-installation, there are no entries in /dev/nvidia, and the only device that appears in lspci is the bridge:

00:00.0 PCI bridge: NVIDIA Corporation Device 0e13 (rev a1)

I have installed cuda-repo-l4t-r19.2_6.0-42_armhf.deb, installed the packages listed

I’ve added the user (ubuntu) to the video group

I have reboot many times, but still nothing shows up in /dev/nvidia*

Help?

I think there are no /dev/nvidia* files but /dev/nvhost* files. But those might be there even without the user space drivers so they might not tell anything about whether or not the user space drivers are installed.

It seems /dev/nvidia* in the CUDA getting started document should be referred as /dev/nvhost* for L4T.

In my case, the problem was solved after changing permissions of the device files from 600 to 666 by the following command.

sudo chmod 666 /dev/nv*