interface closes immediately after opening


I am trying to use to enable SPI on my Jetson Nano as described in the following guide: RS485 CAN for Jetson Nano - Waveshare Wiki

When I run sudo /opt/nvidia/jetson-io/, the interface appears for a moment, but then immediately closes, both when running it directly on the Jetson Nano terminal and when accessing it via SSH.

I have tried updating the system, using xterm, and creating a Python virtual environment, but the issue persists. When checking the logs, I see the following error:

Traceback (most recent call last):
File “/usr/lib/python3.6/curses/”, line 78, in wrapper
_curses.error: cbreak() returned ERR

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/opt/nvidia/jetson-io/”, line 594, in
File “/usr/lib/python3.6/curses/”, line 100, in wrapper
_curses.error: nocbreak() returned ERR

I would appreciate any help in resolving this issue so that I can use to enable SPI on my Jetson Nano.

Thank you in advance.


  • Modello: Jetson Nano Developer Kit
  • Versione di L4T: R32.7.3
  • Versione di JetPack: 4.6.1
  • Versione di CUDA: 10.2.300

cd to the dir first

Do you use Jetson Nano module with embedded emmc, or the module with SD card slot?

Hi there,

I am assisting my friend with an issue regarding the “” on the Jetson Nano. They have installed Jetpack using the official ISO and are using the microSD version of the Jetson Nano.

Despite the existence of the “” file, it cannot be found or started as a service, even when forcing it to run. Additionally, they have tried different configurations with the “.config” file and have found errors in the system logs that may be related to the issue.

We have checked the following logs:

And we have found the following errors:

“failed to get i2c adapter (-19)”
“Failed to get DSI video mode (-22)”
“tegradc tegradc.0: blank - powerdown”
“Parsing /var/crash/”
“Parsing /var/crash/”
We have also tried different configurations with the “.config” file, including one provided in a forum post, but the issue persists.

Could you please help us with this issue? Any advice or guidance would be greatly appreciated.

Thank you

Hi, is for generating device tree file for testing and it cannot be run as a service. Once you enable the SPI interface, please save it and you can see the dtb file is generated and configured in /boot/extlinux/extlinux.conf. It shall take effect after you reboot the system.

You can run this simple test to make sure it works first:
How to set gpio for spi? - #27 by DaneLLL

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.