Jetson Nano freezes and reboot when I stream from IMX219 camera

Hi all,

I have successfully tested a Pi camera v2 (based on IMX219 image sensor) on my Jetson Nano, with the following command:

gst-launch-1.0 nvarguscamerasrc ! 'video/x-raw(memory:NVMM),width=3820, height=2464, framerate=21/1, format=NV12' ! nvvidconv flip-method=0 ! 'video/x-raw,width=960, height=616' ! nvvidconv ! nvegltransform ! nveglglessink -e

However, when I try to stream with a IMX219-D77 camera (see https://www.waveshare.com/product/imx219-d77.htm ), that mounts the same sensor and uses the same camera board as the RPiv2, the Nano crashes and reboots after 1-2 seconds of streaming. This camera works fine on a Raspberry Pi.

What could be the issue?

I have tried different width/height inputs, running the Nano in 5W and 10W modes, but it does not seem to make a difference.

Thanks!

hello sfrc,

the Nano crashes and reboots after 1-2 seconds of streaming.
did you see camera sensor frames output for preview within 1-2 seconds? suggest recording the screen to see what’s actually going on.

could you please also connect serial console, to gather the failure message while IMX219-D77 starting and crashing the kernel.
thanks

Thank you for your reply.

I can see the camera output on the screen for few second, from one to ten seconds (I have attached a video, sorry for the phone quality). Then the system hangs and reboot after about 30 seconds.

I have connected the serial console, and saved the output printed from the time the stream hangs until the system reboots. I did this 5 times, and got different outputs all times. The logs are all attached.

Thanks.
recording_2.mov (8.8 MB)
logs.zip (8.01 KB)

hello sfrc,

I’ve check your video and it seems the functionality of IMX219-D77 is good.
it should be system issue let Jetson-Nano freeze and reboot.
some of your logs shows i2c transfer timed out and watchdog immediately kick in to reboot the system.
we had some discussion threads talking about Nano’s performance, suggest you refer to Topic 1048640 for Jetson-Nano’s power supply.
thanks

Thank you for looking into this.

I have now powered the board through the pins on the extended header with a power supply (as in https://www.manson.com.hk/product/nrp-2050/ ) at 5 V and a maximum current of 5 A.

However, the problem still persists. When the system freezes, the board is only drawing about 1 A.

Thanks.

I am also having the same issue with the same camera. I can get the default rpi2 camera working with Jetson without any issue. But with the waveshare d77 model, it crashes similar to what happens in your video

Hi achuwilson,

Do you experience the same issue with the Jetson Nano or with another model? It would be interesting to understand whether this problem appears as well in more powerful devices, as the TX2 for example.

Thanks.

I had the same issue with Jetson Nano. Both cameras ( default RPi V2 camera and waveshare d77) works well with Raspberry Pi, but with Jetson Nano, only the default Rpi V2 camera works for me

I have tried to power the Jetson Nano with the power supply suggested in the topic mentioned above (that is, https://www.adafruit.com/product/1995 ). However, the system still freezes when trying to stream. Any suggestions to understand where the problem could be?

Thanks.

hello sfrc,

would like to narrow down the issue.

  1. may I know what’s known system changes you did
  2. could you please re-flash the Jetson-Nano with [Jetson Nano Developer Kit SD Card Image] and confirming you still able to reproduce system freeze and reboot issue.
    thanks

Hi JerryChang,

I have only flashed the SD card image and installed OpenCV and its dependencies through this script: https://github.com/AastaNV/JEP/blob/master/script/install_opencv4.0.0_Nano.sh

I did no other changes to the system.

Thanks.

Hey JerryChang,

I also did a fresh installation on SD card and ran into the same issue. I tried updating the updating the ubuntu software using apt-get, but still it returns the same error

hi all,

FYI,
please refer to below link for cameras using IMX219 that should work with Jetson-Nano:
https://github.com/NVIDIA-AI-IOT/jetbot/issues/29

please also contact your sensor vendor for IMX219-D77’s compatibility
thanks

The same thing happens for my Jetson Nano when using “SainSmart IMX219 Camera Module” (https://www.amazon.com/gp/product/B07HMZ9ZFX/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1) with a raspberry pi camera v2 PCB.
Thanks!

Hi,
Only with Nano (no other peripherals like camera…), you can power the evaluation board with any 5V,4A adaptor. But if camera is connected through USB then 5V adaptor is not good enough. You need to supply at least 5.2V to the Nano. This solves Nano reboot issue. This is based on my experience.

Best,
JSP

I also meet same problem.The Jetson Nano will reboot after 5-10 senconds.

Detals:
Hardware: Jetson Nano
Power : Micro USB
Camera Hardware: IMX-219 77

When i used stand test command, the system will lock and reboot after some time . I can’t see the preview window.it has “/dev/video0” in the system.

Next i used “cheese” to test the camera,It stills not work.“There is no devices”

hello bnhcyrnd,

according to comment #13, you might refer to https://github.com/NVIDIA-AI-IOT/jetbot/issues/29 for cameras using IMX219 that should work with Jetson-Nano, please also contact your sensor vendor for IMX219-D77’s compatibility.

BTW,
suggest you refer to Topic 1048640 for Jetson-Nano’s power supply.
thanks

Help, please. I have the exact same problem as shown in the video with the same waveshare camera. Peculiar thing is that it worked until I reflashed the software to restart a project. Now it just freezes and reboots and does not stream, although it is recognized with ls /dev/video0. I have been troubleshooting and cannot figure it out.

I also have this same issue. Trying to run a Raspberry Pi V2 camera and crashes nearly instantaneously upon launch of the camera stream. I have seen others simply returning their Jetson Nanos as defective and hopefully it does not have to come to that.

I have re-flashed twice now and that seems to not be the issue. Also tried running the detectnet-camera.py script from the Hello AI World files and that also crashes nearly instantly. Any help would be appreciated!

In my case, the Nano camera had been working perfectly after I bonded camera connector and CSI cable with silicon bond.
I am confident that this bond is essential for Nano.

In the next video, you can see that the Nano camera is working perfectly.
https://www.youtube.com/watch?v=AbirWDrvE14