New Nano and IMX219 160 Crashes the devices

Hi there,
I got a Nano yesterday, along with a WaveShare IMX219 160 Camera.
I’ve updated Jetpack to 4.6.1, added a swap file, etc…what seem to be the basics of setting up the Nano. I am running 5V 4A on the barrel jack. I have also increased the memory for the swap file to 10G, and the issue persists.

ls /dev/video* returns video0, so I’m pretty sure that the driver is working.

I run the following to test the CSI camera:
DISPLAY=:0.0 nvgstcapture-1.0

and I get output similar (if not exact) to this post:

Then the Nano freezes and reboots (This goes for any version of nvgstcapture).
I’m unsure of how to get that output piped somewhere so I can link or log it due to the freeze. (I’m not sure of the command, and searching has been unsuccessful).

However, here is output of dmesg | grep imx219 right after booting up after a crash.

[    1.283369] imx219 7-0010: tegracam sensor driver:imx219_v2.0.6
[    1.308275] imx219 8-0010: tegracam sensor driver:imx219_v2.0.6
[    1.331630] imx219 8-0010: imx219_board_setup: error during i2c read probe (-121)
[    1.331696] imx219 8-0010: board setup failed
[    1.331745] imx219: probe of 8-0010 failed with error -121
[    1.484239] vi subdev imx219 7-0010 bound

What else can I do or provide to get some help in diagnosing this? I have a feeling the camera may be faulty, but I’m unsure.


I switched out the camera for the RP2 Camera Module and it worked. It was the old camera causing the issue

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.