Jetson Nano NDIS USB network periodically disconnects with Windows computer

I use the USB network connection to SSH into Jetson Nano and perform other network functions. When I do this from my Linux computer, I have no problems. However, with some Windows computers, for example with my Microsoft Surface Pro 3, I have an issue where the network connection periodically has no connection.

If I ping the Jetson Nano, it will do as follows:
for about 13 seconds, ping returns no problem in<1ms
for some 10 seconds, no connection
for 13 seconds, ping returns again
for 10 seconds, no connection.

This keeps going, periodically connecting and not connecting.

Meanwhile, other USB functions such as the L4T readme, as well as the USB serial connection function perfectly with no problem whatsoever, which indicates to me that this is not an issue with the physical USB connection.

In Windows, the Jetson Nano is seen as a Remote NDIS Compatible Device, and Windows says it has the latest driver version.

If I boot my Surface Pro 3 with an Ubuntu Live USB, the connection also works perfectly.

I have tried this with multiple different versions of JetPack, including the latest 4.5.1, with the same results. I have also tried this with multiple different Jetson Nano units.

I admittedly don’t know much about this USB network interface apart from what is written in the L4T readmes. Is there something I have missed? Why would the USB network connection have this kind of issue, while the USB storage and USB serial connections work just fine? I would like to be able to use the USB network connection with Windows computers, so If you have ideas I would be grateful to hear them.

See also the following video I recorded of the phenomenon. On the left hand side you see the USB serial connection terminal pinging from the Jetson Nano ( to the Windows computer ( On the right hand side, you see the Windows command prompt pinging from the Windows computer to the Jetson Nano


This is depend on the driver implementation on your Surface Pro 3.

Could you try to check that the securty settings and network setting on your surface Pro? before that pls try to disconnect any VPN/wifi/ethernet connection to avoid confuse.