Jetson Nano not starting anymore?


The other day, I was just about booting up my Jetson Nano as I normally do. But something strange happened: I was greeted with the standard login screen of Ubuntu (whereas I should be automatically logged in). I typed my password several times, put I didn’t get logged in and returned to the login screen every time.
Then I made a reboot, but then the Jetson Nano didn’t boot at all. The startup commands were rolling, but then the screen just stayed black, no matter how long I waited. I tried to plug in and out, but this didn’t help either.
This is what I get at startup:

Now this is a really big problem as I need my Nano for a project I’m about to hand in. I have videos and my source code there and I don’t have any copy. I have to get it working, otherwise my whole code will be lost. I’m absolutely sure I didn’t to anything wrong, the last time I used it, I shut it down properly, the board isn’t damaged and I haven’t touched it at all. It literally broke from one day to another.
Any advice how to get it to boot or, if it doesn’t help, get my files somehow?

Thank you very much!

For starters: did try to take out the sd-card and insert it again?

Next: I would suggest to mount the sd-card on another machine/PC and create a backup - or at least copy your most important files.

Thanks for your contribution, but the problem is far more complex than that. Yes, I re-inserted the SD card but this didn’t help.
Worse, since the OS is written on the SD card and therefore, the card is a bootable drive instead of a data storage, I can’t just insert it and copy my files. That does not work, since the files are stored in the format of the Ubuntu system itself.
So I’m in need of a more advanced solution to recover my files, perhaps some moderators would know something?

From Linux you can copy content of a boot drive. Do you have a Linux PC, and can you describe what you want to copy? Windows won’t understand a Linux filesystem, and at first it might look like Linux cannot pretend a binary partition is really a filesystem, but Linux can in fact do this quite easily. The trick is knowing more about the SD card layout, and the data within this, e.g., if it is on a partition, or if it is an actual partition.

If you do have a Linux PC and want to recover something, then monitor “dmesg --follow”, and note what shows up as you insert the SD card. I’ll pretend the SD card shows up as “/dev/mmcblk1”, but it could be anything…the dmesg will tell you what…and then provide the output from (substitute the device name for whatever it might really be for your case):
sudo gdisk -l /dev/mmcblk1

@linuxdev Much thanks for your advice. I don’t really have a Linux PC, will a VM also do?
And what exactly does the command you suggested do? Does it extract all files or just print some kind of output? I also want to make absolutely sure that I don’t accidentaly create or overwrite a partition.

For these purposes a VM will work. You just have to make sure the VM gives you access to the card reader instead of letting the host o/s take it.

Okay, the problem is solved (easier than tought). I can access the card through the file manager without problems. Thanks again for the suggestion!