Jetson Orin Nano Devkit cannot communicate with RTK GPS

Reopening this as issue still persists.


As per the previous suggestion I have updated Jetpack to 5.1.2 (r35.4.1). I am still not able to communicate RTK gps using USB.

I still get the following error when running with ros2 node.

[INFO] [launch]: All log files can be found below /home/robogoat/.ros/log/2024-04-06-22-09-18-130908-robogoat-desktop-10790
[INFO] [launch]: Default logging verbosity is set to INFO
[INFO] [ublox_gps_node-1]: process started with pid [10792]
[ublox_gps_node-1] terminate called after throwing an instance of 'std::runtime_error'
[ublox_gps_node-1]   what():  U-Blox: Could not open serial port :/dev/ttyACM0 open: Permission denied

On running minicom - D /dev/ttyACM0, I am not able to see any data incoming.

Following is Jetpack version,

robogoat@robogoat-desktop:~/jetsonUtilities$ python 
NVIDIA NVIDIA Orin Nano Developer Kit
 L4T 35.4.1 [ JetPack UNKNOWN ]
   Ubuntu 20.04.6 LTS
   Kernel Version: 5.10.120-tegra
 CUDA 11.4.315
   CUDA Architecture: 8.7
 OpenCV version: 4.5.4
   OpenCV Cuda: NO
 Vision Works: NOT_INSTALLED
 VPI: 2.3.9
 Vulcan: 1.3.204
Package: nvidia-jetpack
Version: 5.1.2-b104
Architecture: arm64
Maintainer: NVIDIA Corporation
Installed-Size: 194
Depends: nvidia-jetpack-runtime (= 5.1.2-b104), nvidia-jetpack-dev (= 5.1.2-b104)
Priority: standard
Section: metapackages
Filename: pool/main/n/nvidia-jetpack/nvidia-jetpack_5.1.2-b104_arm64.deb
Size: 29304

Do you re-flash the system through SDKManager? There are partitions in QSPI and if you don’t do clean re-flash, the partitions may not be refreshed.

And please use latest Jetpack 5.1.3.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.