Jetson orin nano RJ45 pymodbusTCP connection can not work

Hello everyone,
I am having trouble When I try to connect a Mitsubishi PLC using an RJ45 Ethernet cable and the pymodbusTCP communication protocol, I am unable to successfully communicate with the PLC using Orin Nano. The command I am using is as follows:

pythonCopy code

from pyModbusTCP.client import ModbusClient
b = ModbusClient('', port=502)
b.write_single_coil(0x2000, True)
#system response "False"

I have tried performing this action using a PC, and it works after setting up the PC’s network IP

We don’t have experience about using the device. Would see if other users can share experience. And not sure if additional driver is required. If it requires additional driver, you may check if it has the driver for aarch64.

I found the answer just now. When connecting to the Ethernet cable, it’s necessary to add a new Wired connection and then manually set the IPv4 IP Address and Netmask. Previously, I used to create a connection directly and skip the configuration process, as this is usually something that can be adjusted later. However, even though this is often resettable, my attempts to reset weren’t effective. Therefore, I tried configuring the settings during the connection creation process, and it worked successfully.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.