Jetson orin nano USB Modbus RTU connection doesn't work

Hello everyone,
I am having trouble when I try to connect to plc via RS485 to USB adapter. The communication method is modbus rtu over usb. I tried to use libmodbus c++ library and the code that works perfectly on my laptop without any changes. I can build my ros workspace with codes inside and libmodbus library without any error in jetson orin nano. In code, modbus_read_registers() function gives a negative value so I think it is the problem with reading serial port. I double checked port permissions and dialout group. I checked the baudrate, port, stopbits, etc.
Has anyone faced an issue like this?
Thank you

It looks similar to
Jetson/L4T/r35.3.x patches -

[USB] nvidia-agx-orin-usb-connection-issues

Please apply the USB firmware and give it a try.

Do I need to reflash the jetson orin nano? I am using SDK Manager for flashing. Can you provide me step to step how can I apply USB firmware?
Thank you for your kind response

Please replace the files:
Serial device hangs after closing, unable to re-open without first unplugging it - #9 by DaneLLL

And re-flash the dvice through SDKManager.

I applied and confirmed the firmware but still got same error. I cant connect to modbus rtu device. I can connect arduino etc.
Thank you

Please try on Orin Nano developer kit and see if you still observe the issue. If you can replicate the issue on developer kit, please share us the steps and we can give it a try.

I am currently using Orin Nano developer kit sorry I forget to mention it. I am getting negative value from modbus_read_register() function on my code which uses libmodbus c++ library with ros. I tried pymodbus library with python code and I got input/output error.

Maybe certain configs have to be enabled for the device. Please help check this with the vendor. For common devices such as USB pendrive or USB cameras, it should work well.

This may be similar to RealSense camera that you would need to install certain additional packages.

I am using the developer kit provided by Nvidia. I use the same library and code on my laptop and it works fine without any additional packages. When I build code and library on Jetson orin nano I got no error but when I try to run the code it can’t read data from Modbus RTU

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.