Jetson tx2 CAN communication Problem

I had a problem while doing CAN communication tutorial with Jetson TX2. Sometimes I started TX2 and follow the steps to enble CAN , the run candump and cansend ,but I could not receive any data. Then I reboot the TX2, and CAN could communicate normally. What’s wrong with TX2?

Which BSP version you are using?
I would recommend you to use Jetpack 4.4 in which Rel32.4 version is there.


Hi! Can you please tell what CAN drivers you are using? We I also have a problem with TX2. I am able to receive data from third party device but cant send any packets with cansend. I am using TI sn65hvd230 drivers. I am updatet to Jetpack 4.4 L4T 32.4.3 but nothing changed.

Hi alexander.bondartsev,

If you still do not resolve the CAN issue, please help to open a new topic. Thanks

Dear kayccc,

I already opened topic: Jetson TX2 CAN bus send problem

Thank you.

Best regards,

how can you update to jetpack4.4,I now use jetpack4.2.can you share your steps? thanks

the problem resolved???

Hello zsjalive,

Updating to Jetpack 4.4 is easy through recovery USB connector provided on jetson TX2 development board.
Just connect jetson with Ubuntu PC with this usb and follow the instructions

Problem solved with using TJA1051/3 CAN transceivers. But not solved with TI sn65hvd230. Looks like some hardware incompatibility.

Best regards,