Jetson utils compiled without numpy

Hello. I have this error:

I executed command: “sudo apt-get —reinstall install python3-numpy python-numpy” and reinstalled jetson-inference, but it didnt help.So i have a question:

Could you explain me please how does the system works if i have 2 (or more) versions of python installed (I have python 3.6 and python 3.7 as default in my system) ?Does it install specific version of numpy for each of them or for only one ?If so, how can i install numpy for python 3.6 and how can i set python 3.6 as default ?


After installing the NumPy, have you recompiled the jetson-utils?

Hi.Yes.I executed command sudo apt-get —reinstall install python3-numpy python-numpy” and reinstalled jetson-inference.

Hi @A98, what does python3 --version show?

To reset Python 3.6 as default, either undo what you did to make Python 3.7 the default, or use update-alternatives like this:

sudo update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.6 1

Also make sure that pip3 --version shows python 3.6.
I would not change the base python from pointing to 2.7 on Ubuntu, only python3.

Hi. python3 --version show 3.7.1.And python 3.7 was default in my system from the start; i didnt do anything to make it default.I executed command: sudo update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.6 1, but ,it seems, it didnt do anything.I couldnt set python 3.6 as default.

What OS and version of Ubuntu are you using? Because on JetPack 4 and Ubuntu 18.04, Python 3.6 is the default version of Python3 out of the box.

I also see in your screenshot you appear to have anaconda running, which may be related to some of your issues regarding the default Python versions. I also haven’t tested jetson-inference in conda/miniforge, and jetson-inference/jetson-utils will install it’s Python bindings under /usr/local/lib/python3.x (not anaconda location)

If you continue having issues, I recommend that you try the jetson-inference docker container, as it already has everything pre-installed for you with the correct Python environment and configuration.

Thanks for your reply.I installed the docker container, but i couldnt execute my programm on it, so could you explain me, please, how to import my files in the container to execute my programm ?
I tried this command “docker/ --volume /my/host/path:/my/container/path”, but it didnt work.

No such file or directory error, but it exists in the Jupiter folder on my desktop, so import operation failed.

As for the version, i dont know which version my ubuntu has, but i installed it by this guide :, and from this image.

The container didn’t start, because there was an erroneous $ symbol in your command. Try it again without that.

Then once you are in the container, the prompt should change to showing root user and a # symbol. Then cd /home/atlas/jetson-inference (this is the location you mounted your volume into the container at). Then run ls and see if you see Then you can try to run with python3

It worked.Thanks a lot.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.