Jetson Xavier NX board Camera Error

How to Change imx219 to imx477 in jetpack 4.6.2.
I’m using Jetson Xavier Nx. I tried Changing with but its not changing.

I want to use the following camera,

I have tried Editing the /boot/extlinux/extlinux.conf, but no use.

the following Forum tried.

Any Help Toward It will be Helpfull. Thanks IN advance.

hello garva3583,

are you using Xavier NX developer kit?
may I know what’s the messages by using Jetson-IO to configure CSI.
please also share the kernel init messages for reference, $ dmesg > klogs.txt

klogs.txt (65.0 KB)
here is the Klogs.txt, i wish i got thee correct one, but now the is also not opening

yes i’m using Xavier NX developer kit

hello garva3583,

it looks system still parsing cameras with IMX219 camera configurations.
for example,

[    5.204083] imx219 9-0010: tegracam sensor driver:imx219_v2.0.6
[    5.227556] tegra-i2c 3180000.i2c: no acknowledge from address 0x10
[    5.228879] imx219 9-0010: imx219_board_setup: error during i2c read probe (-121)
[    5.230220] imx219 9-0010: board setup failed

may I also know what did you meant is also not opening.
don’t you see menu for CSI configuration? are you running with root permission?

Hi Garva,
Are you able to use IMX477 with Xavier NX?

Thank you

Yeah now, I’m able to use IMX477 in Xavier Nx. with Jetpack 4.6.3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.