A205 + 6x CSI IMX477


I bought “reComputer J2012 - Edge AI Device with Jetson Xavier NX 16 GB module, Aluminium case, pre-installed JetPack System” and took out this Jetson Xavier NX 16GB production module and installed on A205 (A205 Carrier Board for Jetson Nano/Xavier NX by SeeedStudio). So, its basically both seeedstudio’s A206 + NX 16 production module. I’m trying to get this thing working with “Arducam 12MP IMX477 Motorized Focus HQ Camera Module for Jetson Nano/Xavier NX” for a week now and I need help.

Basically if i flash the device WITHOUT updating dtb files, bootloader, and kernel image then the machine works, there are NO errors at startup like “failed to start docker application container Engine”, “Failed to load kernel modules (resolv.conf)”, “failed to start nvp model service” and I can switch power modes (for example from 10W to 20W etc) and for exaple jetson_stats “jtop” doesnt work also. Also, then i need to commend out xorg.config “nvidia driver” in order to but display working. But I don’t have additional CSI or other additional esources when I view it with (i2cdetect -l). But I need CSI for cameras.

If i install kernel modules (like described here: A20X Carrier Boards Serials Getting Started - Seeed Wiki
A20X Carrier Board - Seeed Wiki (seeedstudio.com)) the “i2cdetect -l” shows a lot more lines and when I see startup log’s then I see that something is trying to detect 6 times IMX231 cameras (I have imx477). I have then i2c but there are problems described on last paragraph.

I have tried 4.6 (rev3), 4.6.1, 4.6.2 and different drivers, no luck, or no understanding what i have to do. Now i read that use apocnz is fighting with the same problem and he added that TensorRT doesnt work without JetPack 5.0.1. :) - or should i try 4.5?

I think there is maybe multiple different problems. The kernel add-on somehow destroys the Jetson knowledge about hardware (why? it doesnt like production module?) and the IMX233 driver doesn’t allow IMX477 to work (need to remove it) + this kernel files (from seeedstudio wiki) somehow broke the Jetson software dependencies. Actually I don’t know what to do.

I need to get working NX 16GB with 6 CSI cameras (IMX477) - what do you thing what could be the easiest solution to get it running? Have someone got it working? Any good suggestions?

To buy new cameras (I liked IMX477 high framerate)?
To wait for JetPack 5.0.2 production realease for few days? (don’t know if it supports A205)
To use something else?

Do you have for example working installation files for Xavier NX 16 prod + A205?

Could you please help me in this matter. Thank you. :)

hello raul.orav,

first of all, it’s a customer carrier board.
it’ll need to refer to Jetson Xavier NX Series Adaptation and Bring-Up to complete some software changes to support this carrier board.
moving to new production release won’t resolve this issue, you should based-on the shipped binary file, which should include those modifications and binaries updates.

I bet your carrier board vendor has modify the device tree for using the main platform device tree file, it always detect IMX231 as they’re default support camera modules for this carrier board.

you may contact with the vendor at first place, please confirm whether IMX477 supported or not.
if they did not disable IMX477 camera driver from kernel images. the detour solution could be disassembler the dtb file into text file, and you modify the code to enable IMX477 manually.
i.e. $ dtc -I dtb -O dts -o output.dts tegra194.dtb
after that, please convert the DTS into a new DTB file,
i.e. $ dtc -I dts -O dtb -o tegra194-new-output.dtb output.dts

1 Like

thnx. I’ll write here what was the solution.

I managed to get Jetson up with " A205_XavierNX_4.6.2.zip - Google Drive" and everything is working like it should, except cameras. Havent tested TensorRT but i belive it is also working. So, I’m going easiest way and buying IMX231 cameras.

By the way. Everything worked, except TensorRT.

NX 16 doesnt support 4.6.0

NX 16 and jetpack 4.6.1 doesnt work with jetson inference :) the problem is NX 16, must use NX8

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.